<!DOCTYPE html><html class="no-js" lang="en" xmlns:fb="http://www.facebook.com/2008/fbml" prefix="og: http://ogp.me/ns#" itemscope itemtype="http://schema.org/Article"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"><meta charset="utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><title>Today&#39;s Ted Takes  |  New Haven Independent</title><meta name='keywords' content='Paul Bass, New Haven, Connecticut, New Haven Connecticut, CT, New Haven news, news about New Haven, Toni Harp' /><meta name='robots' content='index,nofollow,archive' /><link rel='canonical' href='http://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/' /><meta property="og:locale" content="en_US"/><meta property="og:type" content="article" /><meta property="fb:app_id" content="180817351933668" /><meta property="article:published_time" content="2018-06-07T11:30:18-0400" /><meta property="article:modified_time" content="2018-06-07T11:30:19-0400" /><meta property="og:title" content='Today&#39;s Ted Takes  |  New Haven Independent' /><meta property="og:image" content="http://www.newhavenindependent.org/archives/upload/2018/06/misc/ted65.jpg" /><meta property="og:image:width" content="720" /><meta property="og:image:height" content="727" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@newhavenindy" /><meta name="description" property='og:description' content="" /><meta name="twitter:description" content="" /><meta property="og:site_name" content="New Haven Independent" /><meta property="og:url" content="http://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/"/> <script>function loadCSS(e, t, n) { "use strict"; var i = window.document.createElement("link"); var o = t || window.document.getElementsByTagName("script")[0]; i.rel = "stylesheet"; i.href = e; i.media = "only x"; o.parentNode.insertBefore(i, o); setTimeout(function () { i.media = n || "all" }) }
    loadCSS("//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css","","all");
    loadCSS("//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css");</script> <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script> <script type="text/javascript">if (typeof jQuery === 'undefined') {
    var jq = document.createElement('script');
     jq.type = "text/javascript";
     jq.async = 'false';
     jq.src = "/bower_components/jquery/dist/jquery.min.js";
    document.getElementsByTagName('head')[0].appendChild(jq);
}</script> <link rel="dns-prefetch" href="https://d37kg87gb15l4p.cloudfront.net" /> <script src="/assets/js/min/checknprep-min.js"></script> <!--[if lt IE 9]><![endif]--> <!--[if IE 9]><link rel="stylesheet" href="/assets/css/app.css?v=1528335644" /> <![endif]--><!--[if gt IE 9]><!--><link id="ojpStyle" rel="stylesheet" href="/assets/css/app.css?v=201806061740" /><!--<![endif]--> <script src="/assets/js/min/head-first-min.js" async></script> <script>WebFontConfig = {

  google: { families: [ 'Open Sans:400italic,700italic,400,700' ]
       }
};
(function() {
   var wf = document.createElement('script');
   wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
       '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
   wf.type = 'text/javascript';
   wf.async = 'true';
   var s = document.getElementsByTagName('script')[0];
   s.parentNode.insertBefore(wf, s);
 })();</script> <script type="application/ld+json">{
      "@context": "http://schema.org",
      "@type": "Organization",
      "url": "http://www.newhavenindependent.org",
      "logo": "http://www.newhavenindependent.org/assets/img/nh_header_retina_2015_2c.svg"
    }</script> <link rel="dns-prefetch" href="//s7.addthis.com/"> <script type='text/javascript'>var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-2847199-1']);
  _gaq.push(['_setDomainName', '.newhavenindependent.org']);
  _gaq.push(['_trackPageview']);</script> <script type="text/javascript">var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();</script> <link rel="alternate" type="application/rss+xml" title="RSS" href="http://www.newhavenindependent.org/index.php/feeds/rss_2.0/" /><link rel="alternate" type="application/atom+xml" title="Atom" href="http://www.newhavenindependent.org/index.php/feeds/atom/" /></head><body class="entry"><div id="fb-root"></div><script>window.fbAsyncInit = function() {
FB.init({ appId : '180817351933668', autoLogAppEvents : true, xfbml : true, version : 'v2.10' }); FB.AppEvents.logPageView(); }; (function(d, s, id) {  var js, fjs = d.getElementsByTagName(s)[0];  if (d.getElementById(id)) return;  js = d.createElement(s); js.id = id;  js.src = "//connect.facebook.net/en_US/sdk.js";  fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script> <div id="ojp-wrapper" class="ojp-wrapper"><div id="ojp-lining" class="ojp-lining"> <nav class="m-nav small-16 hidden-for-medium-up columns"><div class="wnhh__junkbox hide-for-medium-up"><button class="wnhh__btn"><a href="javascript:;" style="color: white" onclick="MyWindow=window.open('http://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;"><span class="image-replace">WNHH</span></a><ul class="wnhh__switcher"><li><a href="javascript:;" style="color: white" onclick="MyWindow=window.open('http://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;" id="js-rotating"></a></li></ul></button><div id="teenyRadio" class="all-the-stuff row reveal-modal" data-reveal aria-labelledby="teenyRadio" aria-hidden="true" role="dialog"><div id="wnhh__options" class="wnhh__options small-16 columns"><h4>Listen Online:</h4><div class="row collapse"> <a href="https://itunes.apple.com/us/podcast/wnhh-community-radio/id1027927746?mt=2" target="_blank" class="wnhh__somewhere podcast-btn"></a> <a href="https://soundcloud.com/new-haven-independent"  target="_blank" class="wnhh__somewhere soundcloud-btn"></a> <a href="http://tunein.com/radio/WNHH-LP-1035-s247921/" target="_blank" class="wnhh__somewhere tunein-btn"></a> <a href="#" onclick="MyWindow=window.open('http://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;" class="wnhh__somewhere wnhh-here-btn"></a></div></div> <a class="close-reveal-modal" aria-label="Close">&#215;</a></div></div><p class="toggle-panel  js-fr-offcanvas-open"></p></nav><div id="ojp-container" class="container row collapse" data-equalizer="ie9" data-equalizer-mq="medium-up"><div id="far-left" class="far-left ie9-hfix show-for-large-up hide-for-print small-3 column"
data-equalizer-watch="ie9"><div class="inner-wrap-left large-16 columns"><h3 class="h_top sidebar-header">Sections</h3><form name="catmenu" id="ncLeft" action=""> <select name="selcat" onchange="location=document.catmenu.selcat.options[document.catmenu.selcat.selectedIndex].value;"><option value="">choose</option><option value=" /index.php/archives/category/arts/"><a href="http://www.newhavenindependent.org/index.php/archives/category/arts/">Arts & Culture</a></option><option value=" /index.php/archives/category/Crosswords/"><a href="http://www.newhavenindependent.org/index.php/archives/category/Crosswords/">Crosswords</a></option><option value=" /index.php/archives/category/film/"><a href="http://www.newhavenindependent.org/index.php/archives/category/film/">Film</a></option><option value=" /index.php/archives/category/funnies/"><a href="http://www.newhavenindependent.org/index.php/archives/category/funnies/">Op-Art</a></option><option value=" /index.php/archives/category/music/"><a href="http://www.newhavenindependent.org/index.php/archives/category/music/">Music</a></option><option value=" /index.php/archives/category/theater/"><a href="http://www.newhavenindependent.org/index.php/archives/category/theater/">Theater</a></option><option value=" /index.php/archives/category/tv/"><a href="http://www.newhavenindependent.org/index.php/archives/category/tv/">TV/Radio</a></option><option value=" /index.php/archives/category/black_lives_matter/"><a href="http://www.newhavenindependent.org/index.php/archives/category/black_lives_matter/">Black Lives Matter</a></option><option value=" /index.php/archives/category/businesslabor_economic_development/"><a href="http://www.newhavenindependent.org/index.php/archives/category/businesslabor_economic_development/">Business/ Economic Development</a></option><option value=" /index.php/archives/category/citizen_contributions/"><a href="http://www.newhavenindependent.org/index.php/archives/category/citizen_contributions/">Citizen Contributions</a></option><option value=" /index.php/archives/category/city_hall/"><a href="http://www.newhavenindependent.org/index.php/archives/category/city_hall/">City Hall</a></option><option value=" /index.php/archives/category/environment/"><a href="http://www.newhavenindependent.org/index.php/archives/category/environment/">Environment</a></option><option value=" /index.php/archives/category/food/"><a href="http://www.newhavenindependent.org/index.php/archives/category/food/">Food</a></option><option value=" /index.php/archives/category/gay_rights/"><a href="http://www.newhavenindependent.org/index.php/archives/category/gay_rights/">Gay Rights</a></option><option value=" /index.php/archives/category/hamden/"><a href="http://www.newhavenindependent.org/index.php/archives/category/hamden/">Hamden</a></option><option value=" /index.php/archives/category/healthcare/"><a href="http://www.newhavenindependent.org/index.php/archives/category/healthcare/">Health</a></option><option value=" /index.php/archives/category/higher_ed/"><a href="http://www.newhavenindependent.org/index.php/archives/category/higher_ed/">Higher Ed</a></option><option value=" /index.php/archives/category/hometown_heroes/"><a href="http://www.newhavenindependent.org/index.php/archives/category/hometown_heroes/">Hometown Heroes</a></option><option value=" /index.php/archives/category/housing/"><a href="http://www.newhavenindependent.org/index.php/archives/category/housing/">Housing</a></option><option value=" /index.php/archives/category/immigrant_tales/"><a href="http://www.newhavenindependent.org/index.php/archives/category/immigrant_tales/">Immigrants</a></option><option value=" /index.php/archives/category/international/"><a href="http://www.newhavenindependent.org/index.php/archives/category/international/">International</a></option><option value=" /index.php/archives/category/labor/"><a href="http://www.newhavenindependent.org/index.php/archives/category/labor/">Labor</a></option><option value=" /index.php/archives/category/legal_writes/"><a href="http://www.newhavenindependent.org/index.php/archives/category/legal_writes/">Legal Writes</a></option><option value=" /index.php/archives/category/lgbtq/"><a href="http://www.newhavenindependent.org/index.php/archives/category/lgbtq/">LGBTQ</a></option><option value=" /index.php/archives/category/media_books/"><a href="http://www.newhavenindependent.org/index.php/archives/category/media_books/">Media</a></option><option value=" /index.php/archives/category/neighborhoods/"><a href="http://www.newhavenindependent.org/index.php/archives/category/neighborhoods/">Neighborhoods</a></option><option value=" /index.php/archives/category/opinion/"><a href="http://www.newhavenindependent.org/index.php/archives/category/opinion/">Opinion</a></option><option value=" /index.php/archives/category/parks/"><a href="http://www.newhavenindependent.org/index.php/archives/category/parks/">Parks</a></option><option value=" /index.php/archives/category/politics/"><a href="http://www.newhavenindependent.org/index.php/archives/category/politics/">Politics</a></option><option value=" /index.php/archives/category/religion/"><a href="http://www.newhavenindependent.org/index.php/archives/category/religion/">Religion</a></option><option value=" /index.php/archives/category/schools/"><a href="http://www.newhavenindependent.org/index.php/archives/category/schools/">Schools</a></option><option value=" /index.php/archives/category/science_medical/"><a href="http://www.newhavenindependent.org/index.php/archives/category/science_medical/">Science/ Medical</a></option><option value=" /index.php/archives/category/serials/"><a href="http://www.newhavenindependent.org/index.php/archives/category/serials/">Serials</a></option><option value=" /index.php/archives/category/social_services/"><a href="http://www.newhavenindependent.org/index.php/archives/category/social_services/">Social Services</a></option><option value=" /index.php/archives/category/sports/"><a href="http://www.newhavenindependent.org/index.php/archives/category/sports/">Sports</a></option><option value=" /index.php/archives/category/state/"><a href="http://www.newhavenindependent.org/index.php/archives/category/state/">State</a></option><option value=" /index.php/archives/category/2018_session/"><a href="http://www.newhavenindependent.org/index.php/archives/category/2018_session/">2018 Session</a></option><option value=" /index.php/archives/category/transportation/"><a href="http://www.newhavenindependent.org/index.php/archives/category/transportation/">Transportation</a></option><option value=" /index.php/archives/category/wnhh_radio/"><a href="http://www.newhavenindependent.org/index.php/archives/category/wnhh_radio/">WNHH Radio</a></option></select></form><h3 class="sidebar-header">Neighborhoods</h3><form name="catmenu2" id="ncLeft2" action=""> <select name="selcat2" onchange="location=document.catmenu2.selcat2.options[document.catmenu2.selcat2.selectedIndex].value;"><option value="">choose</option><option value="http://www.newhavenindependent.org/index.php/archives/category/amity/">Amity/ Beverly Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/beaver_hills/">Beaver Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/bishop_woods/">Bishop Woods/ Q Meadows</option><option value="http://www.newhavenindependent.org/index.php/archives/category/cedar_hill/">Cedar Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/chatham_square/">Chatham Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/city_point/">City Point</option><option value="http://www.newhavenindependent.org/index.php/archives/category/dixwell/">Dixwell</option><option value="http://www.newhavenindependent.org/index.php/archives/category/downtown/">Downtown</option><option value="http://www.newhavenindependent.org/index.php/archives/category/dwight/">Dwight</option><option value="http://www.newhavenindependent.org/index.php/archives/category/east_rock/">East Rock</option><option value="http://www.newhavenindependent.org/index.php/archives/category/prospect_hill/">Prospect Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/edgewood/">Edgewood</option><option value="http://www.newhavenindependent.org/index.php/archives/category/fair_haven/">Fair Haven</option><option value="http://www.newhavenindependent.org/index.php/archives/category/goatville/">Goatville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/jocelyn_square/">Jocelyn Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/kimberly_square/">Kimberly Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/long_wharf/">Long Wharf</option><option value="http://www.newhavenindependent.org/index.php/archives/category/mill_river/">Mill River</option><option value="http://www.newhavenindependent.org/index.php/archives/category/morris_cove/">Morris Cove</option><option value="http://www.newhavenindependent.org/index.php/archives/category/newhallville/">Newhallville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/ninth_square/">Ninth Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/quinnipiac_river_village/">Quinnipiac River Village</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_annex/">The Annex</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_heights/">The Heights</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_hill/">The Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/trowbridge_square/">Trowbridge Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/upper_state_street/">Upper State Street</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_hills/">West Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_river/">West River</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_rock/">West Rock</option><option value="http://www.newhavenindependent.org/index.php/archives/category/westville/">Westville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/whalley/">Whalley</option><option value="http://www.newhavenindependent.org/index.php/archives/category/wooster_square/">Wooster Square</option></select></form><h3 class="sidebar-header">Features</h3><form name="catmenu3" id="ncLeft3" action=""> <select name="selcat3" onchange="location=document.catmenu3.selcat3.options[document.catmenu3.selcat3.selectedIndex].value;"><option value="">choose</option><option value="http://www.newhavenindependent.org/index.php/archives/category/1_Day_3_Neighborhoods/">1 Day, 3 Neighborhoods</option><option value="http://www.newhavenindependent.org/index.php/archives/category/24_hours/">24 Hours</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2013/">Campaign 2013</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2017/">Campaign 2017</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2018/">Campaign 2018</option><option value="http://www.newhavenindependent.org/index.php/archives/category/chef_of_the_week/">Chef Of The Week</option><option value="http://www.newhavenindependent.org/index.php/archives/category/city_budget/">City Budget</option><option value="http://www.newhavenindependent.org/index.php/archives/category/cop_of_the_week/">Cop of the Week</option><option value="http://www.newhavenindependent.org/index.php/archives/category/ct_bus_diaries/">CT Bus Diaries</option><option value="http://www.newhavenindependent.org/index.php/archives/category/jobs_pipeline/">Jobs Pipeline</option><option value="http://www.newhavenindependent.org/index.php/archives/category/news_from_the_pews/">News From The Pews</option><option value="http://www.newhavenindependent.org/index.php/archives/category/prison_diary/">Prison Diaries</option><option value="http://www.newhavenindependent.org/index.php/archives/category/true_vote/">True Vote</option></select></form><h3 class="radio-far-left sidebar-header" title="Click the button to the right to open the WNHH player">WNHH Radio <a class="fa fa-lg fa-play-circle-o" href="#" onClick="MyWindow=window.open('http://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;"></a></h3><ul id="ncLeft_radio" class="nav_categories"><li class="e_84227"><a href="https://soundcloud.com/new-haven-independent/sets/book-talk-with-cyd-oppenheimer">Book Talk</a></li><li class="e_82732"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven-season-3-0">Dateline New Haven</a></li><li class="e_84259"><a href="http://www.deepfocusradio.com/">Deep Focus</a></li><li class="e_85220"><a href="http://www.rdwolff.com/">Economic Update</a></li><li class="e_87184"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven">Friday Pundits</a></li><li class="e_87356"><a href="http://www.uglyradio.net/Home/">Joe Ugly Show</a></li><li class="e_85223"><a href="https://soundcloud.com/new-haven-independent/sets/kicas-corner">Kica's Corner</a></li><li class="e_84263"><a href="https://soundcloud.com/new-haven-independent/sets/kitchen-sync-with-lucy-gellman">Kitchen Sync</a></li><li class="e_84262"><a href="https://soundcloud.com/new-haven-independent/sets/lovebabz-lovetalk">LoveBabz LoveTalk</a></li><li class="e_87185"><a href="http://www.newhavenindependent.org/index.php/archives/category/mayor_monday/">Mayor Monday!</a></li><li class="e_84001"><a href="https://soundcloud.com/new-haven-independent/sets/mornings-with-mubarakah">Mornings with Mubarakah</a></li><li class="e_84000"><a href="https://soundcloud.com/new-haven-independent/sets/northern-remedy">Northern Remedy</a></li><li class="e_83998"><a href="https://soundcloud.com/new-haven-independent/sets/michelles-turners-the-show">The Show</a></li><li class="e_90951"><a href="https://soundcloud.com/new-haven-independent/sets/the-table-underground">The Table Underground</a></li><li class="e_84260"><a href="https://soundcloud.com/new-haven-independent/sets/alisas-culture-cocktail">The Talk-Sip</a></li><li class="e_83995"><a href="https://soundcloud.com/new-haven-independent/sets/the-tom-ficklin-show">The Tom Ficklin Show</a></li></ul><h3 class="sidebar-header">Follow Us</h3><div id="nhi_fl_soc"><a id="nhi_fb" href="http://www.facebook.com/pages/New-Haven-Independent/10572556227" title="Follow New Haven Independent on facebook"></a><a id="nhi_twit" href="http://www.twitter.com/newhavenindy" title="Follow New Haven Independent on twitter"></a></div><h3 class="sidebar-header">NHI Newsletter</h3><div id="nhi_ml"><a href="http://visitor.r20.constantcontact.com/manage/optin/ea?v=001pNRQhF_J28cEm9r79IJdng%3D%3D" title="Sign up for the NHI Newsletter"></a></div><h3  class="sidebar-header">Legal Notices</h3><ul id="ncLeft_legal" class="nav_categories"><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aascc_legal_notices/">Agency On Aging</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aldermen/">Aldermen</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/housing_authority/">Housing Authority</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/public_meetings/">City Clerk</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/other/">Other</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/probate_court/">Probate</a></li></ul><h3 class="sidebar-header">Government/ Community Links</h3><ul class="linklist"><li><a rel="external" href="http://www.rkidsct.org/">&#8216;r Kids Family Center</a></li><li><a rel="external" href="http://www.aoascc.org/">Agency on Aging</a></li><li><a rel="external" href="http://www.apnh.org">AIDS Project NH</a></li><li><a rel="external" href="http://www.traumainformedschools.org">ALIVE</a></li><li><a rel="external" href="http://www.allourkin.org">All Our Kin</a></li><li><a rel="external" href="http://www.findafriendforlife.org">Animal Shelter Volunteers</a></li><li><a rel="external" href="http://www.arte-inc.com">Arte Inc.</a></li><li><a rel="external" href="http://www.newhavenarts.org">Arts Council</a></li><li><a rel="external" href="http://www.artsinct.org">Arts In CT</a></li><li><a rel="external" href="http://artspacenh.org">Artspace</a></li><li><a rel="external" href="http://www.beki.org">Beth El Keser Israel</a></li><li><a rel="external" href="http://www.bbbsswct.org">Big Brothers Big Sisters</a></li><li><a rel="external" href="http://bikenewhaven.com/">Bike New Haven</a></li><li><a rel="external" href="http://www.bgcnewhaven.org">Boys &amp; Girls Club</a></li><li><a rel="external" href="http://www.cancersupportcommunitysct.org">Cancer Support</a></li><li><a rel="external" href="http://www.WestvilleChabad.com">Chabad of Westville</a></li><li><a rel="external" href="http://www.gnhcc.com">Chamber of Commerce</a></li><li><a rel="external" href="http://www.childrensbuilding.org/">Children&#8217;s Museum</a></li><li><a rel="external" href="http://www.ccahelping.org/">Christian Community Action</a></li><li><a rel="external" href="http://www.cityofnewhaven.com">City of New Haven</a></li><li><a rel="external" href="http://www.cityseed.org/">CitySeed</a></li><li><a rel="external" href="http://www.cwyc.org">Citywide Youth</a></li><li><a rel="external" href="http://www.columbushouse.org">Columbus House</a></li><li><a rel="external" href="http://www.caanh.net/">Community Action Agency</a></li><li><a rel="external" href="http://www.gnhclf.org">Community Loan Fund</a></li><li><a rel="external" href="http://www.community-mediation.org">Community Mediation</a></li><li><a rel="external" href="http://www.conncan.org/matriarch/default.asp">ConnCAN</a></li><li><a rel="external" href="http://www.cornellscott.org">Cornell Scott&#8212;Hill Health Center</a></li><li><a rel="external" href="http://www.creativeartsworkshop.org/">Creative Arts Workshop</a></li><li><a rel="external" href="http://www.connecticut.baeo.org">CT BAEO</a></li><li><a rel="external" href="http://www.ctbestrestaurants.com/">CT Best Restaurants</a></li><li><a rel="external" href="http://www.ct.org/">CT Tech Council</a></li><li><a rel="external" href="http://www.ctdatahaven.org">Data Haven</a></li><li><a rel="external" href="http://www.ecoworksct.org">EcoWorks</a></li><li><a rel="external" href="http://groups.yahoo.com/group/elmcitycycling/">Elm City Cycling</a></li><li><a rel="external" href="http://www.elmshakespeare.org">Elm Shakespeare</a></li><li><a rel="external" href="http://www.elmseed.org">Elmseed</a></li><li><a rel="external" href="http://www.empowernewhaven.org">Empower NH</a></li><li><a rel="external" href="http://www.friendsofwoostersquare.org/">Friends Of Wooster Sq.</a></li><li><a rel="external" href="http://www.grandnewhaven.com">GAVA</a></li><li><a rel="external" href="http://www.ctgmc.org/">Gay Men&#8217;s Chorus</a></li><li><a rel="external" href="http://www.gnhcc.org">GNH Community Chorus</a></li><li><a rel="external" href="http://www.habitatgnh.org">Habitat For Humanity</a></li><li><a rel="external" href="http://www.historicwoostersquare.org/">Historic Wooster Sq. Assn.</a></li><li><a rel="external" href="http://www.infonewhaven.com">Info New Haven</a></li><li><a rel="external" href="http://www.infonewhaven.com/calendar">INFO NH Calendar</a></li><li><a rel="external" href="http://www.irisct.org">IRIS</a></li><li><a rel="external" href="http://jazzhaven.org">Jazz Haven</a></li><li><a rel="external" href="http://www.jewishnewhaven.org">Jewish Federation</a></li><li><a rel="external" href="http://NewHavenCountyJobs.com">Job Finder</a></li><li><a rel="external" href="http://www.juntainc.org/">Junta</a></li><li><a rel="external" href="http://www.laborhistory.org/">Labor History</a></li><li><a rel="external" href="http://www.newhavenfindalawyer.org">Lawyer Finder</a></li><li><a rel="external" href="http://www.leapforkids.org">LEAP</a></li><li><a rel="external" href="http://www.ctnla.org/">Legal Aid Network</a></li><li><a rel="external" href="http://www.libertycs.org">Liberty Safe Haven</a></li><li><a rel="external" href="http://www.lifehaven.org/">Life Haven</a></li><li><a rel="external" href="http://www.literacyeveryday.org">Literacy Coalition</a></li><li><a rel="external" href="http://www.magrissoforte.com">Magrisso Forte</a></li><li><a rel="external" href="http://www.marywade.org/">Mary Wade</a></li><li><a rel="external" href="http://www.musichavenct.org">Music Haven</a></li><li><a rel="external" href="http://www.neighborhoodmusicschool.org/">Neighborhood Music School</a></li><li><a rel="external" href="http://newhaven828.typepad.com/828/">New Haven 828</a></li><li><a rel="external" href="http://www.newhavenchorale.org/">New Haven Chorale</a></li><li><a rel="external" href="http://www.newhavenfarms.org/">New Haven Farms</a></li><li><a rel="external" href="http://www.newhavenmuseum.org">New Haven Museum</a></li><li><a rel="external" href="http://www.newhavenreads.org/">New Haven Reads</a></li><li><a rel="external" href="http://www.newlifecorp.org">New Life Corp.</a></li><li><a rel="external" href="http://www.newreach.org">New Reach</a></li><li><a rel="external" href="http://www.newhavenbirdclub.com">NH Bird Club</a></li><li><a rel="external" href="http://www.newhavenlandtrust.org">NH Land Trust</a></li><li><a rel="external" href="http://www.newhavensymphony.org">NH Symphony</a></li><li><a rel="external" href="http://www.newhavenleon.org">NH/Leon Sister City</a></li><li><a rel="external" href="http://www.nhsofnewhaven.org">NHS</a></li><li><a rel="external" href="http://ontheroadtogreenness.blogspot.com/">On The Road To Greenness</a></li><li><a rel="external" href="http://www.orchardstreetshul.org/">Orchard Street Shul</a></li><li><a rel="external" href="http://www.orchestranewengland.org">Orchestra NE</a></li><li><a rel="external" href="http://www.pathct.org">Parents Available to Help</a></li><li><a rel="external" href="http://www.housedems.ct.gov/Dillon/index.asp">Pat Dillon</a></li><li><a rel="external" href="http://peacenews.org">Peace News</a></li><li><a rel="external" href="http://www.PKN-NewHaven.Org">PechaKucha</a></li><li><a rel="external" href="http://www.ppsne.org">Planned Parenthood</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/Police/index.asp">Police</a></li><li><a rel="external" href="http://par-newhaven.org/">Progressive Action Roundtable</a></li><li><a rel="external" href="http://www.pepeace.org">Promoting Enduring Peace</a></li><li><a rel="external" href="http://www.publicallies.org">Public Allies CT</a></li><li><a rel="external" href="http://www.nhfpl.org/services/community">Public Library</a></li><li><a rel="external" href="http://www.nhps.net">Public Schools</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/PublicWorks/index.asp">Public Works</a></li><li><a rel="external" href="http://www.ctiorg.org/">Rainbow Girls</a></li><li><a rel="external" href="http://entertainment.ctcentral.com/html/index.php">Register Calendar</a></li><li><a rel="external" href="http://www.rexdevelopment.org/">REX</a></li><li><a rel="external" href="http://www.theroofproject.org">ROOF</a></li><li><a rel="external" href="http://www.samact.org/about/loan_funds.shtml">SAMA</a></li><li><a rel="external" href="http://www.scrcog.org/">SCRCOG</a></li><li><a rel="external" href="http://www.southernct.edu/calendar/">SCSU Events</a></li><li><a rel="external" href="http://wflcenter.wordpress.com/">Share Our Voices</a></li><li><a rel="external" href="http://www.shubert.com">Shubert</a></li><li><a rel="external" href="http://www.solaryouth.com/">Solar Youth</a></li><li><a rel="external" href="http://freewebs.com/soul-o-ettes">Soul-O-Ettes</a></li><li><a rel="external" href="http://www.squashhaven.org/">Squash Haven</a></li><li><a rel="external" href="http://www.uwgnh.org">United Way</a></li><li><a rel="external" href="http://www.urbandesignleague.wordpress.com/">Urban Design League</a></li><li><a rel="external" href="http://www.urbanresourcesinitiative.org">Urban Resources Initiative</a></li><li><a rel="external" href="http://www.woostersquareblossom.blogspot.com/">W. Square Blossoms</a></li><li><a rel="external" href="http://www.rwater.com">Water Authority</a></li><li><a rel="external" href="http://westrocktrails.blogspot.com/">West Rock Trails</a></li><li><a rel="external" href="http://www.westvillect.org/">Westville Renaissance</a></li><li><a rel="external" href="http://www.westvilleshul.org">Westville Synagogue</a></li><li><a rel="external" href="https://www.facebook.com/groups/1466587933354636">What Now New Haven</a></li><li><a rel="external" href="http://www.woostersquarewatch.com">Wooster Sq. Watch</a></li><li><a rel="external" href="http://www.workforcealliance.biz">Workforce Alliance</a></li><li><a rel="external" href="http://events.yale.edu/opa/ChooseDate.jsp">Yale Events</a></li><li><a rel="external" href="http://www.cccymca.org/">YMCA</a></li><li><a rel="external" href="http://www.youthcontinuum.org">Youth Continuum</a></li></ul></div></div><div  id="ojp-content" class="content small-16 medium-12 large-10 columns" data-equalizer-watch="ie9"><div class="header-wrap row collapse"> <header class=" header small-16 columns"  role="banner"><div class="row"> <nav id="navable" class="navable__logged-out top-nav small-16 column"> <a class="menu-navlink hide-for-large-up" href="#main-menu"><span></span>menu</a> <a class="loggie" data-reveal-id="nhi-login" href="javascript:;" title="Login for New Haven Independent"  rel="loggin"><span></span>Login</a> <span class="evEnter"></span><div id="nhi-login" class="nhi-login reveal-modal" data-reveal aria-labelledby="nh_loginTitle" aria-hidden="true" role="dialog"><div id="ee_logform" class="loggin"><form id='loggin' method="post" action="http://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="9" /> <input type="hidden" name="RET" value="http://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/" /> <input type="hidden" name="site_id" value="3" /></div><fieldset><div class="row"><div class="large-16 columns logForm"><h4 id="nh_loginTitle" class="form-title">New Haven Independent Login Form</h4> <label for="username">username</label> <input type="text" name="username" value="" maxlength="32" class="input" size="20" /> <input class='checkbox' type='checkbox' name='auto_login' value='1' /> Auto-login on future visits</div></div><div class="row"><div class="large-16 columns logForm"><label for="password">password</label> <input type="password" name="password" value="" maxlength="32" class="input" size="20" /> <a href="http://www.newhavenindependent.org/index.php/participate/forgot_password/">Forgot your password?</a></div></div><div class="row"><div class="large-16 columns logForm"><button type="submit" name="submit" value="Submit" class="logan">submit</button></div></div></fieldset></form></div><a class="close-reveal-modal" aria-label="Close">&#215;</a></div><ul class="utility-menu sf-menu nav right show-for-medium-up"><li class="li_1"><span class="sf-with-ul">Info &amp; Contact</span><ul><li class="li_1"><span class="sf-with-ul">About</span><ul><li><a href="http://www.newhavenindependent.org/index.php/about_nhi/">New Haven Independent</a></li><li><a href="http://www.newhavenindependent.org/index.php/about_ojp/">Online Journalism Project</a></li></ul></li><li><a href="http://www.newhavenindependent.org/index.php/get_in_touch/">Contact</a></li><li><a href="http://www.newhavenindependent.org/index.php/site_policies/">Site Policies</a></li><li class="hide-for-large-up"><a href="http://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></li><li class="utility__donate show-for-large-up"><a href="http://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></nav></div><div id="upscroll" class="upscroll"><div class="nhi_hdr small-16 columns"><div class="branding small-16 medium-16 large-16" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="New Haven Independent"><a href="/">New Haven Independent</a></div></div></div><div class="row collapse"><nav id="secondary-nav" class="secondary-nav small-16 columns"> <nav id="seeAlso" class="secondary__seeAlso"> <a class="be_nav" href='http://www.newhavenindependent.org/index.php/branford/' title="Branford Eagle">Branford Eagle</a> <a class="vis_nav" href='http://valley.newhavenindependent.org' title="Valley Independent Sentinel">Valley Independent Sentinel</a> <a class="lv_nav" href="http://lavozhispanact.com/" title="La Voz Hispana">La Voz</a> </nav><div id="lookwrap" class="lookwrap"><form method="post" action="http://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="19" /> <input type="hidden" name="XID" value="" /> <input type="hidden" name="RP" value="search/results" /> <input type="hidden" name="NRP" value="" /> <input type="hidden" name="RES" value="" /> <input type="hidden" name="status" value="not closed|Pending" /> <input type="hidden" name="weblog" value="not sponsors" /> <input type="hidden" name="search_in" value="everywhere" /> <input type="hidden" name="where" value="all" /> <input type="hidden" name="site_id" value="3" /></div><div id="lookr" class="lookr row"><div class="search-box btn-group"><label for="keywords">Search:</label><input type="text" name="keywords" id="keywords" value="" placeholder="search New Haven Independent" class="search-field"  /><span class="clear-icon fa fa-times-circle"></span><button  class="submit search fa fa-search" type="submit" value="submit"><span>submit</span></button></div></div></form></div> </nav></div> <nav id="main-menu"  class="fin_nav nav"><ul><li class="mm-divider"><span>NHI Info &amp; Contact</span><ul id="fs_nav" class="nav"><li class="li_1"><span>About</span><ul><li><a href="http://www.newhavenindependent.org/index.php/about_nhi/">New Haven Independent</a></li><li><a href="http://www.newhavenindependent.org/index.php/about_ojp/">Online Journalism Project</a></li></ul></li><li><a href="http://www.newhavenindependent.org/index.php/get_in_touch/">Contact</a></li><li><a href="http://www.newhavenindependent.org/index.php/site_policies/">Site Policies</a></li><li><a href="http://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></li><li class="mm-divider show-for-small-only"><a href="http://www.newhavenindependent.org/index.php/ee/P00/">Extra Extra</a></li><li class="mm-divider"><span>Sections</span><ul><li><a href="index.php/archives/category/arts/">Arts & Culture</a><ul><li><a href="index.php/archives/category/Crosswords/">Crosswords</a></li><li><a href="index.php/archives/category/film/">Film</a></li><li><a href="index.php/archives/category/funnies/">Op-Art</a></li><li><a href="index.php/archives/category/music/">Music</a></li><li><a href="index.php/archives/category/theater/">Theater</a></li><li><a href="index.php/archives/category/tv/">TV/Radio</a></li></ul></li><li><a href="index.php/archives/category/black_lives_matter/">Black Lives Matter</a></li><li><a href="index.php/archives/category/businesslabor_economic_development/">Business/ Economic Development</a></li><li><a href="index.php/archives/category/citizen_contributions/">Citizen Contributions</a></li><li><a href="index.php/archives/category/city_hall/">City Hall</a></li><li><a href="index.php/archives/category/environment/">Environment</a></li><li><a href="index.php/archives/category/food/">Food</a></li><li><a href="index.php/archives/category/gay_rights/">Gay Rights</a></li><li><a href="index.php/archives/category/hamden/">Hamden</a></li><li><a href="index.php/archives/category/healthcare/">Health</a></li><li><a href="index.php/archives/category/higher_ed/">Higher Ed</a></li><li><a href="index.php/archives/category/hometown_heroes/">Hometown Heroes</a></li><li><a href="index.php/archives/category/housing/">Housing</a></li><li><a href="index.php/archives/category/immigrant_tales/">Immigrants</a></li><li><a href="index.php/archives/category/international/">International</a></li><li><a href="index.php/archives/category/labor/">Labor</a></li><li><a href="index.php/archives/category/legal_writes/">Legal Writes</a></li><li><a href="index.php/archives/category/lgbtq/">LGBTQ</a></li><li><a href="index.php/archives/category/media_books/">Media</a></li><li><a href="index.php/archives/category/neighborhoods/">Neighborhoods</a></li><li><a href="index.php/archives/category/opinion/">Opinion</a></li><li><a href="index.php/archives/category/parks/">Parks</a></li><li><a href="index.php/archives/category/politics/">Politics</a></li><li><a href="index.php/archives/category/religion/">Religion</a></li><li><a href="index.php/archives/category/schools/">Schools</a></li><li><a href="index.php/archives/category/science_medical/">Science/ Medical</a></li><li><a href="index.php/archives/category/serials/">Serials</a></li><li><a href="index.php/archives/category/social_services/">Social Services</a></li><li><a href="index.php/archives/category/sports/">Sports</a></li><li><a href="index.php/archives/category/state/">State</a><ul><li><a href="index.php/archives/category/2018_session/">2018 Session</a></li></ul></li><li><a href="index.php/archives/category/transportation/">Transportation</a></li><li><a href="index.php/archives/category/wnhh_radio/">WNHH Radio</a></li></ul></li><li class="mm-divider"><span>Neighborhoods</span><ul><li><a href="http://www.newhavenindependent.org/index.php/archives/category/amity/" title="Amity/ Beverly Hills">Amity/ Beverly Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/beaver_hills/" title="Beaver Hills">Beaver Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/bishop_woods/" title="Bishop Woods/ Q Meadows">Bishop Woods/ Q Meadows</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/cedar_hill/" title="Cedar Hill">Cedar Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/chatham_square/" title="Chatham Square">Chatham Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/city_point/" title="City Point">City Point</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/dixwell/" title="Dixwell">Dixwell</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/downtown/" title="Downtown">Downtown</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/dwight/" title="Dwight">Dwight</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/east_rock/" title="East Rock">East Rock</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/prospect_hill/" title="Prospect Hill">Prospect Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/edgewood/" title="Edgewood">Edgewood</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/fair_haven/" title="Fair Haven">Fair Haven</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/goatville/" title="Goatville">Goatville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/jocelyn_square/" title="Jocelyn Square">Jocelyn Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/kimberly_square/" title="Kimberly Square">Kimberly Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/long_wharf/" title="Long Wharf">Long Wharf</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/mill_river/" title="Mill River">Mill River</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/morris_cove/" title="Morris Cove">Morris Cove</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/newhallville/" title="Newhallville">Newhallville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/ninth_square/" title="Ninth Square">Ninth Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/quinnipiac_river_village/" title="Quinnipiac River Village">Quinnipiac River Village</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_annex/" title="The Annex">The Annex</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_heights/" title="The Heights">The Heights</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_hill/" title="The Hill">The Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/trowbridge_square/" title="Trowbridge Square">Trowbridge Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/upper_state_street/" title="Upper State Street">Upper State Street</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_hills/" title="West Hills">West Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_river/" title="West River">West River</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_rock/" title="West Rock">West Rock</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/westville/" title="Westville">Westville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/whalley/" title="Whalley">Whalley</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/wooster_square/" title="Wooster Square">Wooster Square</a></li></ul></li><li class="mm-divider"><span>Features</span><ul><li><a href="https://www.newhavenindependent.org/index.php/archives/category/1_Day_3_Neighborhoods/" title="1 Day, 3 Neighborhoods">1 Day, 3 Neighborhoods</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/24_hours/" title="24 Hours">24 Hours</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2013/" title="Campaign 2013">Campaign 2013</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2017/" title="Campaign 2017">Campaign 2017</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2018/" title="Campaign 2018">Campaign 2018</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/chef_of_the_week/" title="Chef Of The Week">Chef Of The Week</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/city_budget/" title="City Budget">City Budget</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/cop_of_the_week/" title="Cop of the Week">Cop of the Week</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/ct_bus_diaries/" title="CT Bus Diaries">CT Bus Diaries</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/jobs_pipeline/" title="Jobs Pipeline">Jobs Pipeline</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/news_from_the_pews/" title="News From The Pews">News From The Pews</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/prison_diary/" title="Prison Diaries">Prison Diaries</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/true_vote/" title="True Vote">True Vote</a></li></ul></li><li class="mm-divider mm-radio-menu"><span class="mm-wnhh-logo">WNHH Radio</span><ul><li class="e_84227"><a href="https://soundcloud.com/new-haven-independent/sets/book-talk-with-cyd-oppenheimer">Book Talk</a></li><li class="e_82732"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven-season-3-0">Dateline New Haven</a></li><li class="e_84259"><a href="http://www.deepfocusradio.com/">Deep Focus</a></li><li class="e_85220"><a href="http://www.rdwolff.com/">Economic Update</a></li><li class="e_87184"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven">Friday Pundits</a></li><li class="e_87356"><a href="http://www.uglyradio.net/Home/">Joe Ugly Show</a></li><li class="e_85223"><a href="https://soundcloud.com/new-haven-independent/sets/kicas-corner">Kica's Corner</a></li><li class="e_84263"><a href="https://soundcloud.com/new-haven-independent/sets/kitchen-sync-with-lucy-gellman">Kitchen Sync</a></li><li class="e_84262"><a href="https://soundcloud.com/new-haven-independent/sets/lovebabz-lovetalk">LoveBabz LoveTalk</a></li><li class="e_87185"><a href="http://www.newhavenindependent.org/index.php/archives/category/mayor_monday/">Mayor Monday!</a></li><li class="e_84001"><a href="https://soundcloud.com/new-haven-independent/sets/mornings-with-mubarakah">Mornings with Mubarakah</a></li><li class="e_84000"><a href="https://soundcloud.com/new-haven-independent/sets/northern-remedy">Northern Remedy</a></li><li class="e_83998"><a href="https://soundcloud.com/new-haven-independent/sets/michelles-turners-the-show">The Show</a></li><li class="e_90951"><a href="https://soundcloud.com/new-haven-independent/sets/the-table-underground">The Table Underground</a></li><li class="e_84260"><a href="https://soundcloud.com/new-haven-independent/sets/alisas-culture-cocktail">The Talk-Sip</a></li><li class="e_83995"><a href="https://soundcloud.com/new-haven-independent/sets/the-tom-ficklin-show">The Tom Ficklin Show</a></li></ul></li><li class="mm-divider"><span>Legal Notices</span><ul><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aascc_legal_notices/" title="Agency On Aging">Agency On Aging</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aldermen/" title="Board of Alders">Board of Alders</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/housing_authority/" title="Housing Authority">Housing Authority</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/public_meetings/" title="City Clerk">City Clerk</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/other/" title="Other">Other</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/probate_court/" title="Probate">Probate</a></li></ul></li><li class="mm-multiline mm-divider"><span>Government/ Community Links</span><ul class="linklist"><li><a rel="external" href="http://www.rkidsct.org/">&#8216;r Kids Family Center</a></li><li><a rel="external" href="http://www.aoascc.org/">Agency on Aging</a></li><li><a rel="external" href="http://www.apnh.org">AIDS Project NH</a></li><li><a rel="external" href="http://www.traumainformedschools.org">ALIVE</a></li><li><a rel="external" href="http://www.allourkin.org">All Our Kin</a></li><li><a rel="external" href="http://www.findafriendforlife.org">Animal Shelter Volunteers</a></li><li><a rel="external" href="http://www.arte-inc.com">Arte Inc.</a></li><li><a rel="external" href="http://www.newhavenarts.org">Arts Council</a></li><li><a rel="external" href="http://www.artsinct.org">Arts In CT</a></li><li><a rel="external" href="http://artspacenh.org">Artspace</a></li><li><a rel="external" href="http://www.beki.org">Beth El Keser Israel</a></li><li><a rel="external" href="http://www.bbbsswct.org">Big Brothers Big Sisters</a></li><li><a rel="external" href="http://bikenewhaven.com/">Bike New Haven</a></li><li><a rel="external" href="http://www.bgcnewhaven.org">Boys &amp; Girls Club</a></li><li><a rel="external" href="http://www.cancersupportcommunitysct.org">Cancer Support</a></li><li><a rel="external" href="http://www.WestvilleChabad.com">Chabad of Westville</a></li><li><a rel="external" href="http://www.gnhcc.com">Chamber of Commerce</a></li><li><a rel="external" href="http://www.childrensbuilding.org/">Children&#8217;s Museum</a></li><li><a rel="external" href="http://www.ccahelping.org/">Christian Community Action</a></li><li><a rel="external" href="http://www.cityofnewhaven.com">City of New Haven</a></li><li><a rel="external" href="http://www.cityseed.org/">CitySeed</a></li><li><a rel="external" href="http://www.cwyc.org">Citywide Youth</a></li><li><a rel="external" href="http://www.columbushouse.org">Columbus House</a></li><li><a rel="external" href="http://www.caanh.net/">Community Action Agency</a></li><li><a rel="external" href="http://www.gnhclf.org">Community Loan Fund</a></li><li><a rel="external" href="http://www.community-mediation.org">Community Mediation</a></li><li><a rel="external" href="http://www.conncan.org/matriarch/default.asp">ConnCAN</a></li><li><a rel="external" href="http://www.cornellscott.org">Cornell Scott&#8212;Hill Health Center</a></li><li><a rel="external" href="http://www.creativeartsworkshop.org/">Creative Arts Workshop</a></li><li><a rel="external" href="http://www.connecticut.baeo.org">CT BAEO</a></li><li><a rel="external" href="http://www.ctbestrestaurants.com/">CT Best Restaurants</a></li><li><a rel="external" href="http://www.ct.org/">CT Tech Council</a></li><li><a rel="external" href="http://www.ctdatahaven.org">Data Haven</a></li><li><a rel="external" href="http://www.ecoworksct.org">EcoWorks</a></li><li><a rel="external" href="http://groups.yahoo.com/group/elmcitycycling/">Elm City Cycling</a></li><li><a rel="external" href="http://www.elmshakespeare.org">Elm Shakespeare</a></li><li><a rel="external" href="http://www.elmseed.org">Elmseed</a></li><li><a rel="external" href="http://www.empowernewhaven.org">Empower NH</a></li><li><a rel="external" href="http://www.friendsofwoostersquare.org/">Friends Of Wooster Sq.</a></li><li><a rel="external" href="http://www.grandnewhaven.com">GAVA</a></li><li><a rel="external" href="http://www.ctgmc.org/">Gay Men&#8217;s Chorus</a></li><li><a rel="external" href="http://www.gnhcc.org">GNH Community Chorus</a></li><li><a rel="external" href="http://www.habitatgnh.org">Habitat For Humanity</a></li><li><a rel="external" href="http://www.historicwoostersquare.org/">Historic Wooster Sq. Assn.</a></li><li><a rel="external" href="http://www.infonewhaven.com">Info New Haven</a></li><li><a rel="external" href="http://www.infonewhaven.com/calendar">INFO NH Calendar</a></li><li><a rel="external" href="http://www.irisct.org">IRIS</a></li><li><a rel="external" href="http://jazzhaven.org">Jazz Haven</a></li><li><a rel="external" href="http://www.jewishnewhaven.org">Jewish Federation</a></li><li><a rel="external" href="http://NewHavenCountyJobs.com">Job Finder</a></li><li><a rel="external" href="http://www.juntainc.org/">Junta</a></li><li><a rel="external" href="http://www.laborhistory.org/">Labor History</a></li><li><a rel="external" href="http://www.newhavenfindalawyer.org">Lawyer Finder</a></li><li><a rel="external" href="http://www.leapforkids.org">LEAP</a></li><li><a rel="external" href="http://www.ctnla.org/">Legal Aid Network</a></li><li><a rel="external" href="http://www.libertycs.org">Liberty Safe Haven</a></li><li><a rel="external" href="http://www.lifehaven.org/">Life Haven</a></li><li><a rel="external" href="http://www.literacyeveryday.org">Literacy Coalition</a></li><li><a rel="external" href="http://www.magrissoforte.com">Magrisso Forte</a></li><li><a rel="external" href="http://www.marywade.org/">Mary Wade</a></li><li><a rel="external" href="http://www.musichavenct.org">Music Haven</a></li><li><a rel="external" href="http://www.neighborhoodmusicschool.org/">Neighborhood Music School</a></li><li><a rel="external" href="http://newhaven828.typepad.com/828/">New Haven 828</a></li><li><a rel="external" href="http://www.newhavenchorale.org/">New Haven Chorale</a></li><li><a rel="external" href="http://www.newhavenfarms.org/">New Haven Farms</a></li><li><a rel="external" href="http://www.newhavenmuseum.org">New Haven Museum</a></li><li><a rel="external" href="http://www.newhavenreads.org/">New Haven Reads</a></li><li><a rel="external" href="http://www.newlifecorp.org">New Life Corp.</a></li><li><a rel="external" href="http://www.newreach.org">New Reach</a></li><li><a rel="external" href="http://www.newhavenbirdclub.com">NH Bird Club</a></li><li><a rel="external" href="http://www.newhavenlandtrust.org">NH Land Trust</a></li><li><a rel="external" href="http://www.newhavensymphony.org">NH Symphony</a></li><li><a rel="external" href="http://www.newhavenleon.org">NH/Leon Sister City</a></li><li><a rel="external" href="http://www.nhsofnewhaven.org">NHS</a></li><li><a rel="external" href="http://ontheroadtogreenness.blogspot.com/">On The Road To Greenness</a></li><li><a rel="external" href="http://www.orchardstreetshul.org/">Orchard Street Shul</a></li><li><a rel="external" href="http://www.orchestranewengland.org">Orchestra NE</a></li><li><a rel="external" href="http://www.pathct.org">Parents Available to Help</a></li><li><a rel="external" href="http://www.housedems.ct.gov/Dillon/index.asp">Pat Dillon</a></li><li><a rel="external" href="http://peacenews.org">Peace News</a></li><li><a rel="external" href="http://www.PKN-NewHaven.Org">PechaKucha</a></li><li><a rel="external" href="http://www.ppsne.org">Planned Parenthood</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/Police/index.asp">Police</a></li><li><a rel="external" href="http://par-newhaven.org/">Progressive Action Roundtable</a></li><li><a rel="external" href="http://www.pepeace.org">Promoting Enduring Peace</a></li><li><a rel="external" href="http://www.publicallies.org">Public Allies CT</a></li><li><a rel="external" href="http://www.nhfpl.org/services/community">Public Library</a></li><li><a rel="external" href="http://www.nhps.net">Public Schools</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/PublicWorks/index.asp">Public Works</a></li><li><a rel="external" href="http://www.ctiorg.org/">Rainbow Girls</a></li><li><a rel="external" href="http://entertainment.ctcentral.com/html/index.php">Register Calendar</a></li><li><a rel="external" href="http://www.rexdevelopment.org/">REX</a></li><li><a rel="external" href="http://www.theroofproject.org">ROOF</a></li><li><a rel="external" href="http://www.samact.org/about/loan_funds.shtml">SAMA</a></li><li><a rel="external" href="http://www.scrcog.org/">SCRCOG</a></li><li><a rel="external" href="http://www.southernct.edu/calendar/">SCSU Events</a></li><li><a rel="external" href="http://wflcenter.wordpress.com/">Share Our Voices</a></li><li><a rel="external" href="http://www.shubert.com">Shubert</a></li><li><a rel="external" href="http://www.solaryouth.com/">Solar Youth</a></li><li><a rel="external" href="http://freewebs.com/soul-o-ettes">Soul-O-Ettes</a></li><li><a rel="external" href="http://www.squashhaven.org/">Squash Haven</a></li><li><a rel="external" href="http://www.uwgnh.org">United Way</a></li><li><a rel="external" href="http://www.urbandesignleague.wordpress.com/">Urban Design League</a></li><li><a rel="external" href="http://www.urbanresourcesinitiative.org">Urban Resources Initiative</a></li><li><a rel="external" href="http://www.woostersquareblossom.blogspot.com/">W. Square Blossoms</a></li><li><a rel="external" href="http://www.rwater.com">Water Authority</a></li><li><a rel="external" href="http://westrocktrails.blogspot.com/">West Rock Trails</a></li><li><a rel="external" href="http://www.westvillect.org/">Westville Renaissance</a></li><li><a rel="external" href="http://www.westvilleshul.org">Westville Synagogue</a></li><li><a rel="external" href="https://www.facebook.com/groups/1466587933354636">What Now New Haven</a></li><li><a rel="external" href="http://www.woostersquarewatch.com">Wooster Sq. Watch</a></li><li><a rel="external" href="http://www.workforcealliance.biz">Workforce Alliance</a></li><li><a rel="external" href="http://events.yale.edu/opa/ChooseDate.jsp">Yale Events</a></li><li><a rel="external" href="http://www.cccymca.org/">YMCA</a></li><li><a rel="external" href="http://www.youthcontinuum.org">Youth Continuum</a></li></ul></li></ul></nav> </header></div><div class="row ctr-wrap" data-equalizer="ctr" data-equalizer-mq="medium-up" data-equalizer-watch="ie9"><div id="ctr" class="entry-ctr small-16 columns"><meta itemscope itemprop="mainEntityOfPage" itemid="http://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/"/><h1 class="entry-title" itemprop="headline">Today&#8217;s Ted Takes</h1><p class="posted entry__info" itemprop="author" itemscope itemtype="https://schema.org/Person">by <span class="auth entry-author-name" itemprop="name"> Ted Littleford </span> |  Jun 7, 2018  7:30&nbsp;am</p><p class="spec_list entry__info"> <a href="#p_cmt">Post a Comment</a> | <a href="#e_auth"   data-reveal-id="e_auth" title="E-mail the Author">E-mail the Author</a></p><p class="p_cat entry__info">Posted to: <a href="http://www.newhavenindependent.org/index.php/archives/category/arts/">Arts & Culture</a>, <a href="http://www.newhavenindependent.org/index.php/archives/category/funnies/">Op-Art</a></p><div id="entryCtr" class="entry-content" itemprop="articleBody"><meta itemprop="datePublished" content="2018-06-07T07:30:18-0400"/><meta itemprop="dateModified" content="2018-06-07T07:30:19-0400"/><p> <img class="imgcaption wDefault" src="/images/made/archives/upload/2018/06/misc/ted65_720_727_88_sha-100.jpg" itemprop="thumbnailUrl" width="720" height="727" title="" alt="" /></p><p> <img class="imgcaption wDefault" src="/images/made/archives/upload/2018/06/misc/tl65_720_727_88_sha-100.jpg" itemprop="image" width="720" height="727" title="" alt="" /></p></div> <img class="no" src='http://www.newhavenindependent.org/index.php?ACT=113&amp;vars=YToyOntzOjg6ImVudHJ5X2lkIjtzOjY6IjEwNTA0NiI7czo5OiJ3ZWJsb2dfaWQiO3M6MjoiMTAiO30=' /><div id="e_auth" class="e_auth reveal-modal" data-reveal aria-labelledby="nh_emailAuthorTitle" aria-hidden="true" role="dialog" style="display: none;"><form id='contact_form' method="post" action="http://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="20" /> <input type="hidden" name="RET" value="" /> <input type="hidden" name="URI" value="/archives/entry/todays_ted_take4/" /> <input type="hidden" name="recipients" value="1+tq6FTEn1O9OcR88yJdRv5RfMYEQDK3U/jd5t7jb1c=" /> <input type="hidden" name="user_recipients" value="7a44810c6a31cd13c20d2554443c0c5e" /> <input type="hidden" name="charset" value="utf-8" /> <input type="hidden" name="redirect" value="" /> <input type="hidden" name="replyto" value="" /> <input type="hidden" name="site_id" value="3" /></div><input type="hidden" name="to" size="40" value="editor@newhavenindependent.org" readonly /><p><label for="from">Your Email:</label><br /> <input type="text" id="from" name="from" size="60" maxlength="45" value=""/></p><p><label for="subject">Subject:</label><br /> <input type="text" id="subject" name="subject" size="60" value="Contact Ted Littleford Re:Today&#8217;s Ted Takes" readonly /></p><p><label for="message">Message:</label><br /><textarea id="message" name="message" rows="18" cols="40">
Sent: Jun 7, 2018  7:47 am</textarea></p><p>Please enter the word you see in the image below:</p><p><img src="http://events.newhavenindependent.org/images/captchas/1528372042.7687.jpg" width="140" height="30" style="border:0;" alt=" " /><br /> <input type="text" name="captcha" value="" maxlength="20" /></p><p><button type="submit" name="submit" value="Submit Form" class="logan">submit</button></p> <a class="close-reveal-modal" aria-label="Close">&#215;</a></form></div><div id="share" class="share"><p class="socB">Share this story with others.</p><div class="addthis_inline_share_toolbox_msqo_xojq" addthis:url="https://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/" addthis:title="Today&#8217;s Ted Takes"></div><p id="facebook_like"></p></div><h3 id="p_cmt">Post a Comment</h3><h4>You must be logged in to comment</h4><p><strong>If you already have an account</strong>, please <a class="btn" href="javascript:;" data-reveal-id="nhi-login">log in here</a> | If not, please <span class="evEnter"></span>.</p><h3 id="cmt">Comments</h3><div class="cmt_body"><p>Be the first to comment</p></div> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f2021f347757e15" async></script> <script type="text/javascript" language="javascript" defer>jQuery(document).ready(function() {
jQuery('#facebook_like').socialbutton('facebook_like', {
    button: 'standard',
    url: 'https://www.newhavenindependent.org/index.php/archives/entry/todays_ted_take4/',
    encoded: true,
    show_faces: false,
    width: 550,
    height: 20,
    action: 'recommend',
    colorscheme: 'light'
});
});</script> </div></div></div><div id="farRight" class="far-right mm-pageshadow ie9-hfix hide-for-print medium-4 large-3 column" data-equalizer-watch="ie9"> <section class="inner-wrap" data-navigation-handle=".toggle-panel" data-navigation-content=".content" > <aside class="this-maybe"><h3 id="e_Cal" class="e_cal"><a href="http://events.newhavenindependent.org/">Events Calendar</a></h3><div id="eventCal" class="eventCal nh_sidecal lazy" data-src="/events/index.php/calendar/nhi_cal_sidebar/"><p id="calloading" class="calloading">loading…</p></div><h3 id="scf" class="scf"><a href="http://www.seeclickfix.com/new-haven" target="_blank">SeeClickFix &raquo;</a></h3><div id="seeclickfix" class="seeclickfix  c_event"><dl class="vevent"><dt class="summary"><a href="https://seeclickfix.com/issues/3920910">Tree Trimming</a></dt><dd class="sched dtstart">Dec 1, 2017 12:18 pm</dd><dd class="description">Address: 213 Maple St New Haven, Connecticut Rating: 1</dd></dl><dl class="vevent"><dt class="summary"><a href="https://seeclickfix.com/issues/3920867">(EONP)11 Huntington Ave.</a></dt><dd class="sched dtstart">Dec 1, 2017 12:02 pm</dd><dd class="description">Address: 11 Huntington Ave New Haven, CT 06512, USA Rating: 1</dd></dl></div><h3 id="nhi_bb" class="nhi_bb">PosterWall<a href="//www.newhavenindependent.org/index.php/posterwall/">Add your Poster</a></h3><div id="ojp-bb-tv" class="bb lazy" data-src="https://truevote.newhavenindependent.org/billboard"></div><div id="feed_links" class="feed_links"><h3>News Feeds</h3> <a class="rss_feed" href="http://www.newhavenindependent.org/index.php/feeds/rss_2.0/" title="Subscribe to the New Haven Independent RSS Feed">N.H.I. <abbr title="Really Simple Syndication">RSS 2.0 Feed</abbr></a> <a class="rss_feed" href="http://www.newhavenindependent.org/index.php/feeds/atom/" title="Subscribe to the New Haven Independent Atom Feed">N.H.I. Atom Feed</a></div><div id="sponsors" class="sponsors-banners"><h3>Sponsors</h3><div id="nhi_sponsors" class="nhi_sponsors sponsors"> <a id="Sponsor2" href="http://www.cfgnh.org/" target="_blank" title="The Community Foundation for Greater New Haven"></a><div id="seedlings"></div><a id="Sponsor4" href="http://betsygrauerrealty.com/" target="_blank" title="Betsy Grauer Realty"></a><div id="Sponsor5"></div><a id="sponsor_YNHH" href="https://www.ynhh.org" target="_blank" title="Visit Discover YNHH"></a> <a id="sponsor_KF" href="http://knightfoundation.org/" target="_blank" title="Visit Knight Foundation"></a></div><h3 id="h_spd" class="h_spd">N.H.I. Site Design &amp; Development</h3> <a id="dev" class="dev" href="http://smartpilldesign.com/" title="site by Smartpill Design">smartpill design</a></div></aside> </section></div></div><div class="footer row"><footer id="footer" class="footer small-16 medium-16 columns"><div class="row"><div class="footwrap small-16 columns"><p class="f_left copyright">&copy;2005 &ndash; 2018 <a href="http://newhavenindependent.org" title="visit New Haven Independent">New Haven Independent</a></p><p class="f_right spd"> site: <a href="http://smartpilldesign.com/" target="_blank" title="visit smartpilldesign.com">smartpilldesign</a></p></div></div> </footer></div></div></div> <script type="text/javascript" src="/assets/js/min/ojp.entry-plugins-min.js?v=1701171515"></script> <script src="/assets/js/min/plugins-min.js?v=1528337637"></script> <script type="text/javascript" src="/assets/js/min/ojp_entry-min.js?v=1701171511"></script> <script type="text/javascript">(function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();</script>  <script type="text/javascript">_qevents.push( { qacct:"p-a4RoUWp9ToKuU"} );</script> <noscript><div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-a4RoUWp9ToKuU.gif" height="1" width="1" alt="Quantcast"/></div> </noscript></body></html>