<!DOCTYPE html><html class="no-js" lang="en" xmlns:fb="http://www.facebook.com/2008/fbml" prefix="og: http://ogp.me/ns#" itemscope itemtype="http://schema.org/Article"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"><meta charset="utf-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><title>Post-Death, Henry Green&#8217;s Story Continues  |  New Haven Independent</title><meta name='keywords' content='Paul Bass, New Haven, Connecticut, New Haven Connecticut, CT, New Haven news, news about New Haven, Toni Harp' /><meta name='robots' content='index,nofollow,archive' /><link rel='canonical' href='http://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/' /><meta property="og:locale" content="en_US"/><meta property="og:type" content="article" /><meta property="fb:app_id" content="180817351933668" /><meta property="article:published_time" content="2018-08-21T19:44:21-0400" /><meta property="article:modified_time" content="2018-08-21T21:19:22-0400" /><meta property="og:title" content='Post-Death, Henry Green&#8217;s Story Continues  |  New Haven Independent' /><meta property="og:image" content="http://www.newhavenindependent.org/archives/upload/2018/08/David/David-Henroles-Screenshot_2018-08-19_07.04.58.jpg" /><meta property="og:image:width" content="690" /><meta property="og:image:height" content="914" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@newhavenindy" /><meta name="description" property='og:description' content="{media_10}A bullet that pierced Henry Harris Green IV, aka Renegade, on a Newhallville street eight years ago, and remained lodged in his body is now evidence in an investigation into..." /><meta name="twitter:description" content="{media_10}A bullet that pierced Henry Harris Green IV, aka Renegade, on a Newhallville street eight years ago, and remained lodged in his body is now evidence in an investigation into..." /><meta property="og:site_name" content="New Haven Independent" /><meta property="og:url" content="https://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/"/> <script>function loadCSS(e, t, n) { "use strict"; var i = window.document.createElement("link"); var o = t || window.document.getElementsByTagName("script")[0]; i.rel = "stylesheet"; i.href = e; i.media = "only x"; o.parentNode.insertBefore(i, o); setTimeout(function () { i.media = n || "all" }) }
    loadCSS("//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css","","all");
    loadCSS("//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css");</script> <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script> <script type="text/javascript">if (typeof jQuery === 'undefined') {
    var jq = document.createElement('script');
     jq.type = "text/javascript";
     jq.async = 'false';
     jq.src = "/bower_components/jquery/dist/jquery.min.js";
    document.getElementsByTagName('head')[0].appendChild(jq);
}</script> <link rel="dns-prefetch" href="https://d37kg87gb15l4p.cloudfront.net" /> <script src="/assets/js/min/checknprep-min.js"></script> <!--[if lt IE 9]><![endif]--> <!--[if IE 9]><link rel="stylesheet" href="/assets/css/app.css?v=1528426869" /> <![endif]--><!--[if gt IE 9]><!--><link id="ojpStyle" rel="stylesheet" href="/assets/css/app.css?v=201806071901" /><!--<![endif]--> <script src="/assets/js/min/head-first-min.js" async></script> <script>WebFontConfig = {

  google: { families: [ 'Open Sans:400italic,700italic,400,700' ]
       }
};
(function() {
   var wf = document.createElement('script');
   wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
       '://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
   wf.type = 'text/javascript';
   wf.async = 'true';
   var s = document.getElementsByTagName('script')[0];
   s.parentNode.insertBefore(wf, s);
 })();</script> <script type="application/ld+json">{
      "@context": "http://schema.org",
      "@type": "Organization",
      "url": "http://www.newhavenindependent.org",
      "logo": "http://www.newhavenindependent.org/assets/img/nh_header_retina_2015_2c.svg"
    }</script> <link rel="dns-prefetch" href="//s7.addthis.com/"> <script type='text/javascript'>var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-2847199-1']);
  _gaq.push(['_setDomainName', '.newhavenindependent.org']);
  _gaq.push(['_trackPageview']);</script> <script type="text/javascript">var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();</script> <link rel="alternate" type="application/rss+xml" title="RSS" href="https://www.newhavenindependent.org/index.php/feeds/rss_2.0/" /><link rel="alternate" type="application/atom+xml" title="Atom" href="https://www.newhavenindependent.org/index.php/feeds/atom/" /></head><body class="entry"><div id="fb-root"></div><script>window.fbAsyncInit = function() {
FB.init({ appId : '180817351933668', autoLogAppEvents : true, xfbml : true, version : 'v2.10' }); FB.AppEvents.logPageView(); }; (function(d, s, id) {  var js, fjs = d.getElementsByTagName(s)[0];  if (d.getElementById(id)) return;  js = d.createElement(s); js.id = id;  js.src = "//connect.facebook.net/en_US/sdk.js";  fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script> <div id="ojp-wrapper" class="ojp-wrapper"><div id="ojp-lining" class="ojp-lining"> <nav class="m-nav small-16 hidden-for-medium-up columns"><div class="wnhh__junkbox hide-for-medium-up"><button class="wnhh__btn"><a href="javascript:;" style="color: white" onclick="MyWindow=window.open('https://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;"><span class="image-replace">WNHH</span></a><ul class="wnhh__switcher"><li><a href="javascript:;" style="color: white" onclick="MyWindow=window.open('https://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;" id="js-rotating"></a></li></ul></button><div id="teenyRadio" class="all-the-stuff row reveal-modal" data-reveal aria-labelledby="teenyRadio" aria-hidden="true" role="dialog"><div id="wnhh__options" class="wnhh__options small-16 columns"><h4>Listen Online:</h4><div class="row collapse"> <a href="https://itunes.apple.com/us/podcast/wnhh-community-radio/id1027927746?mt=2" target="_blank" class="wnhh__somewhere podcast-btn"></a> <a href="https://soundcloud.com/new-haven-independent"  target="_blank" class="wnhh__somewhere soundcloud-btn"></a> <a href="http://tunein.com/radio/WNHH-LP-1035-s247921/" target="_blank" class="wnhh__somewhere tunein-btn"></a> <a href="#" onclick="MyWindow=window.open('https://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;" class="wnhh__somewhere wnhh-here-btn"></a></div></div> <a class="close-reveal-modal" aria-label="Close">&#215;</a></div></div><p class="toggle-panel  js-fr-offcanvas-open"></p></nav><div id="ojp-container" class="container row collapse" data-equalizer="ie9" data-equalizer-mq="medium-up"><div id="far-left" class="far-left ie9-hfix show-for-large-up hide-for-print small-3 column"
data-equalizer-watch="ie9"><div class="inner-wrap-left large-16 columns"><h3 class="h_top sidebar-header">Sections</h3><form name="catmenu" id="ncLeft" action=""> <select name="selcat" onchange="location=document.catmenu.selcat.options[document.catmenu.selcat.selectedIndex].value;"><option value="">choose</option><option value=" /index.php/archives/category/arts/"><a href="http://www.newhavenindependent.org/index.php/archives/category/arts/">Arts & Culture</a></option><option value=" /index.php/archives/category/Crosswords/"><a href="http://www.newhavenindependent.org/index.php/archives/category/Crosswords/">Crosswords</a></option><option value=" /index.php/archives/category/film/"><a href="http://www.newhavenindependent.org/index.php/archives/category/film/">Film</a></option><option value=" /index.php/archives/category/funnies/"><a href="http://www.newhavenindependent.org/index.php/archives/category/funnies/">Op-Art</a></option><option value=" /index.php/archives/category/music/"><a href="http://www.newhavenindependent.org/index.php/archives/category/music/">Music</a></option><option value=" /index.php/archives/category/theater/"><a href="http://www.newhavenindependent.org/index.php/archives/category/theater/">Theater</a></option><option value=" /index.php/archives/category/tv/"><a href="http://www.newhavenindependent.org/index.php/archives/category/tv/">TV/Radio</a></option><option value=" /index.php/archives/category/black_lives_matter/"><a href="http://www.newhavenindependent.org/index.php/archives/category/black_lives_matter/">Black Lives Matter</a></option><option value=" /index.php/archives/category/businesslabor_economic_development/"><a href="http://www.newhavenindependent.org/index.php/archives/category/businesslabor_economic_development/">Business/ Economic Development</a></option><option value=" /index.php/archives/category/citizen_contributions/"><a href="http://www.newhavenindependent.org/index.php/archives/category/citizen_contributions/">Citizen Contributions</a></option><option value=" /index.php/archives/category/city_hall/"><a href="http://www.newhavenindependent.org/index.php/archives/category/city_hall/">City Hall</a></option><option value=" /index.php/archives/category/environment/"><a href="http://www.newhavenindependent.org/index.php/archives/category/environment/">Environment</a></option><option value=" /index.php/archives/category/food/"><a href="http://www.newhavenindependent.org/index.php/archives/category/food/">Food</a></option><option value=" /index.php/archives/category/gay_rights/"><a href="http://www.newhavenindependent.org/index.php/archives/category/gay_rights/">Gay Rights</a></option><option value=" /index.php/archives/category/hamden/"><a href="http://www.newhavenindependent.org/index.php/archives/category/hamden/">Hamden</a></option><option value=" /index.php/archives/category/healthcare/"><a href="http://www.newhavenindependent.org/index.php/archives/category/healthcare/">Health</a></option><option value=" /index.php/archives/category/higher_ed/"><a href="http://www.newhavenindependent.org/index.php/archives/category/higher_ed/">Higher Ed</a></option><option value=" /index.php/archives/category/hometown_heroes/"><a href="http://www.newhavenindependent.org/index.php/archives/category/hometown_heroes/">Hometown Heroes</a></option><option value=" /index.php/archives/category/housing/"><a href="http://www.newhavenindependent.org/index.php/archives/category/housing/">Housing</a></option><option value=" /index.php/archives/category/immigrant_tales/"><a href="http://www.newhavenindependent.org/index.php/archives/category/immigrant_tales/">Immigrants</a></option><option value=" /index.php/archives/category/international/"><a href="http://www.newhavenindependent.org/index.php/archives/category/international/">International</a></option><option value=" /index.php/archives/category/labor/"><a href="http://www.newhavenindependent.org/index.php/archives/category/labor/">Labor</a></option><option value=" /index.php/archives/category/legal_writes/"><a href="http://www.newhavenindependent.org/index.php/archives/category/legal_writes/">Legal Writes</a></option><option value=" /index.php/archives/category/lgbtq/"><a href="http://www.newhavenindependent.org/index.php/archives/category/lgbtq/">LGBTQ</a></option><option value=" /index.php/archives/category/media_books/"><a href="http://www.newhavenindependent.org/index.php/archives/category/media_books/">Media</a></option><option value=" /index.php/archives/category/neighborhoods/"><a href="http://www.newhavenindependent.org/index.php/archives/category/neighborhoods/">Neighborhoods</a></option><option value=" /index.php/archives/category/opinion/"><a href="http://www.newhavenindependent.org/index.php/archives/category/opinion/">Opinion</a></option><option value=" /index.php/archives/category/parks/"><a href="http://www.newhavenindependent.org/index.php/archives/category/parks/">Parks</a></option><option value=" /index.php/archives/category/politics/"><a href="http://www.newhavenindependent.org/index.php/archives/category/politics/">Politics</a></option><option value=" /index.php/archives/category/religion/"><a href="http://www.newhavenindependent.org/index.php/archives/category/religion/">Religion</a></option><option value=" /index.php/archives/category/schools/"><a href="http://www.newhavenindependent.org/index.php/archives/category/schools/">Schools</a></option><option value=" /index.php/archives/category/science_medical/"><a href="http://www.newhavenindependent.org/index.php/archives/category/science_medical/">Science/ Medical</a></option><option value=" /index.php/archives/category/serials/"><a href="http://www.newhavenindependent.org/index.php/archives/category/serials/">Serials</a></option><option value=" /index.php/archives/category/social_services/"><a href="http://www.newhavenindependent.org/index.php/archives/category/social_services/">Social Services</a></option><option value=" /index.php/archives/category/sports/"><a href="http://www.newhavenindependent.org/index.php/archives/category/sports/">Sports</a></option><option value=" /index.php/archives/category/state/"><a href="http://www.newhavenindependent.org/index.php/archives/category/state/">State</a></option><option value=" /index.php/archives/category/2018_session/"><a href="http://www.newhavenindependent.org/index.php/archives/category/2018_session/">2018 Session</a></option><option value=" /index.php/archives/category/transportation/"><a href="http://www.newhavenindependent.org/index.php/archives/category/transportation/">Transportation</a></option><option value=" /index.php/archives/category/wnhh_radio/"><a href="http://www.newhavenindependent.org/index.php/archives/category/wnhh_radio/">WNHH Radio</a></option></select></form><h3 class="sidebar-header">Neighborhoods</h3><form name="catmenu2" id="ncLeft2" action=""> <select name="selcat2" onchange="location=document.catmenu2.selcat2.options[document.catmenu2.selcat2.selectedIndex].value;"><option value="">choose</option><option value="http://www.newhavenindependent.org/index.php/archives/category/amity/">Amity/ Beverly Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/beaver_hills/">Beaver Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/bishop_woods/">Bishop Woods/ Q Meadows</option><option value="http://www.newhavenindependent.org/index.php/archives/category/cedar_hill/">Cedar Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/chatham_square/">Chatham Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/city_point/">City Point</option><option value="http://www.newhavenindependent.org/index.php/archives/category/dixwell/">Dixwell</option><option value="http://www.newhavenindependent.org/index.php/archives/category/downtown/">Downtown</option><option value="http://www.newhavenindependent.org/index.php/archives/category/dwight/">Dwight</option><option value="http://www.newhavenindependent.org/index.php/archives/category/east_rock/">East Rock</option><option value="http://www.newhavenindependent.org/index.php/archives/category/prospect_hill/">Prospect Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/edgewood/">Edgewood</option><option value="http://www.newhavenindependent.org/index.php/archives/category/fair_haven/">Fair Haven</option><option value="http://www.newhavenindependent.org/index.php/archives/category/goatville/">Goatville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/jocelyn_square/">Jocelyn Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/kimberly_square/">Kimberly Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/long_wharf/">Long Wharf</option><option value="http://www.newhavenindependent.org/index.php/archives/category/mill_river/">Mill River</option><option value="http://www.newhavenindependent.org/index.php/archives/category/morris_cove/">Morris Cove</option><option value="http://www.newhavenindependent.org/index.php/archives/category/newhallville/">Newhallville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/ninth_square/">Ninth Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/quinnipiac_river_village/">Quinnipiac River Village</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_annex/">The Annex</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_heights/">The Heights</option><option value="http://www.newhavenindependent.org/index.php/archives/category/the_hill/">The Hill</option><option value="http://www.newhavenindependent.org/index.php/archives/category/trowbridge_square/">Trowbridge Square</option><option value="http://www.newhavenindependent.org/index.php/archives/category/upper_state_street/">Upper State Street</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_hills/">West Hills</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_river/">West River</option><option value="http://www.newhavenindependent.org/index.php/archives/category/west_rock/">West Rock</option><option value="http://www.newhavenindependent.org/index.php/archives/category/westville/">Westville</option><option value="http://www.newhavenindependent.org/index.php/archives/category/whalley/">Whalley</option><option value="http://www.newhavenindependent.org/index.php/archives/category/wooster_square/">Wooster Square</option></select></form><h3 class="sidebar-header">Features</h3><form name="catmenu3" id="ncLeft3" action=""> <select name="selcat3" onchange="location=document.catmenu3.selcat3.options[document.catmenu3.selcat3.selectedIndex].value;"><option value="">choose</option><option value="http://www.newhavenindependent.org/index.php/archives/category/1_Day_3_Neighborhoods/">1 Day, 3 Neighborhoods</option><option value="http://www.newhavenindependent.org/index.php/archives/category/24_hours/">24 Hours</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2013/">Campaign 2013</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2017/">Campaign 2017</option><option value="http://www.newhavenindependent.org/index.php/archives/category/campaign_2018/">Campaign 2018</option><option value="http://www.newhavenindependent.org/index.php/archives/category/chef_of_the_week/">Chef Of The Week</option><option value="http://www.newhavenindependent.org/index.php/archives/category/city_budget/">City Budget</option><option value="http://www.newhavenindependent.org/index.php/archives/category/cop_of_the_week/">Cop of the Week</option><option value="http://www.newhavenindependent.org/index.php/archives/category/ct_bus_diaries/">CT Bus Diaries</option><option value="http://www.newhavenindependent.org/index.php/archives/category/jobs_pipeline/">Jobs Pipeline</option><option value="http://www.newhavenindependent.org/index.php/archives/category/news_from_the_pews/">News From The Pews</option><option value="http://www.newhavenindependent.org/index.php/archives/category/prison_diary/">Prison Diaries</option><option value="http://www.newhavenindependent.org/index.php/archives/category/true_vote/">True Vote</option></select></form><h3 class="radio-far-left sidebar-header" title="Click the button to the right to open the WNHH player">WNHH Radio <a class="fa fa-lg fa-play-circle-o" href="#" onClick="MyWindow=window.open('http://www.newhavenindependent.org/assets/inc/playerooney.php','WNHHplayer','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizable=no,width=400,height=206'); return false;"></a></h3><ul id="ncLeft_radio" class="nav_categories"><li class="e_84227"><a href="https://soundcloud.com/new-haven-independent/sets/book-talk-with-cyd-oppenheimer">Book Talk</a></li><li class="e_82732"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven-season-3-0">Dateline New Haven</a></li><li class="e_84259"><a href="http://www.deepfocusradio.com/">Deep Focus</a></li><li class="e_85220"><a href="http://www.rdwolff.com/">Economic Update</a></li><li class="e_87184"><a href="https://soundcloud.com/new-haven-independent/sets/pundit-friday-season-2">Friday Pundits</a></li><li class="e_87356"><a href="http://www.uglyradio.net/Home/">Joe Ugly Show</a></li><li class="e_85223"><a href="https://soundcloud.com/new-haven-independent/sets/kicas-corner">Kica's Corner</a></li><li class="e_84263"><a href="https://soundcloud.com/new-haven-independent/sets/kitchen-sync-with-lucy-gellman">Kitchen Sync</a></li><li class="e_84262"><a href="https://soundcloud.com/new-haven-independent/sets/lovebabz-lovetalk">LoveBabz LoveTalk</a></li><li class="e_87185"><a href="http://www.newhavenindependent.org/index.php/archives/category/mayor_monday/">Mayor Monday!</a></li><li class="e_84001"><a href="https://soundcloud.com/new-haven-independent/sets/mornings-with-mubarakah">Mornings with Mubarakah</a></li><li class="e_84000"><a href="https://soundcloud.com/new-haven-independent/sets/northern-remedy">Northern Remedy</a></li><li class="e_83998"><a href="https://soundcloud.com/new-haven-independent/sets/michelles-turners-the-show">The Show</a></li><li class="e_90951"><a href="https://soundcloud.com/new-haven-independent/sets/the-table-underground">The Table Underground</a></li><li class="e_84260"><a href="https://soundcloud.com/new-haven-independent/sets/alisas-culture-cocktail">The Talk-Sip</a></li><li class="e_83995"><a href="https://soundcloud.com/new-haven-independent/sets/the-tom-ficklin-show">The Tom Ficklin Show</a></li></ul><h3 class="sidebar-header">Follow Us</h3><div id="nhi_fl_soc"><a id="nhi_fb" href="http://www.facebook.com/pages/New-Haven-Independent/10572556227" title="Follow New Haven Independent on facebook"></a><a id="nhi_twit" href="http://www.twitter.com/newhavenindy" title="Follow New Haven Independent on twitter"></a></div><h3 class="sidebar-header">NHI Newsletter</h3><div id="nhi_ml"><a href="http://visitor.r20.constantcontact.com/manage/optin/ea?v=001pNRQhF_J28cEm9r79IJdng%3D%3D" title="Sign up for the NHI Newsletter"></a></div><h3  class="sidebar-header">Legal Notices</h3><ul id="ncLeft_legal" class="nav_categories"><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aascc_legal_notices/">Agency On Aging</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aldermen/">Aldermen</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/housing_authority/">Housing Authority</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/public_meetings/">City Clerk</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/other/">Other</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/probate_court/">Probate</a></li></ul><h3 class="sidebar-header">Government/ Community Links</h3><ul class="linklist"><li><a rel="external" href="http://www.rkidsct.org/">&#8216;r Kids Family Center</a></li><li><a rel="external" href="https://www.onecityinitiative.org/">1 City/ 60 Days</a></li><li><a rel="external" href="http://www.aoascc.org/">Agency on Aging</a></li><li><a rel="external" href="http://www.apnh.org">AIDS Project NH</a></li><li><a rel="external" href="http://www.traumainformedschools.org">ALIVE</a></li><li><a rel="external" href="http://www.allourkin.org">All Our Kin</a></li><li><a rel="external" href="http://www.findafriendforlife.org">Animal Shelter Volunteers</a></li><li><a rel="external" href="http://www.arte-inc.com">Arte Inc.</a></li><li><a rel="external" href="http://www.newhavenarts.org">Arts Council</a></li><li><a rel="external" href="http://www.artsinct.org">Arts In CT</a></li><li><a rel="external" href="http://artspacenh.org">Artspace</a></li><li><a rel="external" href="http://www.beki.org">Beth El Keser Israel</a></li><li><a rel="external" href="http://www.bbbsswct.org">Big Brothers Big Sisters</a></li><li><a rel="external" href="https://bikenewhaven.wordpress.com/">Bike New Haven</a></li><li><a rel="external" href="http://www.bgcnewhaven.org">Boys &amp; Girls Club</a></li><li><a rel="external" href="http://www.cancersupportcommunitysct.org">Cancer Support</a></li><li><a rel="external" href="http://www.WestvilleChabad.com">Chabad of Westville</a></li><li><a rel="external" href="http://www.gnhcc.com">Chamber of Commerce</a></li><li><a rel="external" href="http://www.childrensbuilding.org/">Children&#8217;s Museum</a></li><li><a rel="external" href="http://www.ccahelping.org/">Christian Community Action</a></li><li><a rel="external" href="http://www.cityofnewhaven.com">City of New Haven</a></li><li><a rel="external" href="http://www.cityseed.org/">CitySeed</a></li><li><a rel="external" href="http://www.cwyc.org">Citywide Youth</a></li><li><a rel="external" href="http://www.columbushouse.org">Columbus House</a></li><li><a rel="external" href="http://www.caanh.net/">Community Action Agency</a></li><li><a rel="external" href="http://www.gnhclf.org">Community Loan Fund</a></li><li><a rel="external" href="http://www.community-mediation.org">Community Mediation</a></li><li><a rel="external" href="http://www.conncan.org/matriarch/default.asp">ConnCAN</a></li><li><a rel="external" href="http://www.cornellscott.org">Cornell Scott&#8212;Hill Health Center</a></li><li><a rel="external" href="http://www.creativeartsworkshop.org/">Creative Arts Workshop</a></li><li><a rel="external" href="http://www.connecticut.baeo.org">CT BAEO</a></li><li><a rel="external" href="http://www.ctbestrestaurants.com/">CT Best Restaurants</a></li><li><a rel="external" href="http://www.ct.org/">CT Tech Council</a></li><li><a rel="external" href="http://www.ctdatahaven.org">Data Haven</a></li><li><a rel="external" href="http://www.ecoworksct.org">EcoWorks</a></li><li><a rel="external" href="http://groups.yahoo.com/group/elmcitycycling/">Elm City Cycling</a></li><li><a rel="external" href="http://www.elmshakespeare.org">Elm Shakespeare</a></li><li><a rel="external" href="http://www.elmseed.org">Elmseed</a></li><li><a rel="external" href="http://www.empowernewhaven.org">Empower NH</a></li><li><a rel="external" href="http://www.friendsofwoostersquare.org/">Friends Of Wooster Sq.</a></li><li><a rel="external" href="http://www.grandnewhaven.com">GAVA</a></li><li><a rel="external" href="http://www.ctgmc.org/">Gay Men&#8217;s Chorus</a></li><li><a rel="external" href="http://www.gnhcc.org">GNH Community Chorus</a></li><li><a rel="external" href="http://www.habitatgnh.org">Habitat For Humanity</a></li><li><a rel="external" href="http://www.historicwoostersquare.org/">Historic Wooster Sq. Assn.</a></li><li><a rel="external" href="http://www.infonewhaven.com">Info New Haven</a></li><li><a rel="external" href="http://www.infonewhaven.com/calendar">INFO NH Calendar</a></li><li><a rel="external" href="http://www.irisct.org">IRIS</a></li><li><a rel="external" href="http://jazzhaven.org">Jazz Haven</a></li><li><a rel="external" href="http://www.jewishnewhaven.org">Jewish Federation</a></li><li><a rel="external" href="http://NewHavenCountyJobs.com">Job Finder</a></li><li><a rel="external" href="http://www.juntainc.org/">Junta</a></li><li><a rel="external" href="http://www.laborhistory.org/">Labor History</a></li><li><a rel="external" href="http://www.newhavenfindalawyer.org">Lawyer Finder</a></li><li><a rel="external" href="http://www.leapforkids.org">LEAP</a></li><li><a rel="external" href="http://www.ctnla.org/">Legal Aid Network</a></li><li><a rel="external" href="http://www.libertycs.org">Liberty Safe Haven</a></li><li><a rel="external" href="http://www.lifehaven.org/">Life Haven</a></li><li><a rel="external" href="http://www.literacyeveryday.org">Literacy Coalition</a></li><li><a rel="external" href="http://www.magrissoforte.com">Magrisso Forte</a></li><li><a rel="external" href="http://www.marywade.org/">Mary Wade</a></li><li><a rel="external" href="http://www.musichavenct.org">Music Haven</a></li><li><a rel="external" href="http://www.neighborhoodmusicschool.org/">Neighborhood Music School</a></li><li><a rel="external" href="http://newhaven828.typepad.com/828/">New Haven 828</a></li><li><a rel="external" href="http://www.newhavenchorale.org/">New Haven Chorale</a></li><li><a rel="external" href="http://www.newhavenfarms.org/">New Haven Farms</a></li><li><a rel="external" href="http://www.newhavenmuseum.org">New Haven Museum</a></li><li><a rel="external" href="http://www.newhavenreads.org/">New Haven Reads</a></li><li><a rel="external" href="http://www.newlifecorp.org">New Life Corp.</a></li><li><a rel="external" href="http://www.newreach.org">New Reach</a></li><li><a rel="external" href="http://www.newhavenbirdclub.com">NH Bird Club</a></li><li><a rel="external" href="http://www.newhavenlandtrust.org">NH Land Trust</a></li><li><a rel="external" href="http://www.newhavensymphony.org">NH Symphony</a></li><li><a rel="external" href="http://www.newhavenleon.org">NH/Leon Sister City</a></li><li><a rel="external" href="http://www.nhsofnewhaven.org">NHS</a></li><li><a rel="external" href="http://ontheroadtogreenness.blogspot.com/">On The Road To Greenness</a></li><li><a rel="external" href="http://www.orchardstreetshul.org/">Orchard Street Shul</a></li><li><a rel="external" href="http://www.orchestranewengland.org">Orchestra NE</a></li><li><a rel="external" href="http://www.pathct.org">Parents Available to Help</a></li><li><a rel="external" href="http://www.housedems.ct.gov/Dillon/index.asp">Pat Dillon</a></li><li><a rel="external" href="http://peacenews.org">Peace News</a></li><li><a rel="external" href="http://www.PKN-NewHaven.Org">PechaKucha</a></li><li><a rel="external" href="http://www.ppsne.org">Planned Parenthood</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/Police/index.asp">Police</a></li><li><a rel="external" href="http://par-newhaven.org/">Progressive Action Roundtable</a></li><li><a rel="external" href="http://www.pepeace.org">Promoting Enduring Peace</a></li><li><a rel="external" href="http://www.publicallies.org">Public Allies CT</a></li><li><a rel="external" href="http://www.nhfpl.org/services/community">Public Library</a></li><li><a rel="external" href="http://www.nhps.net">Public Schools</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/PublicWorks/index.asp">Public Works</a></li><li><a rel="external" href="http://www.ctiorg.org/">Rainbow Girls</a></li><li><a rel="external" href="http://entertainment.ctcentral.com/html/index.php">Register Calendar</a></li><li><a rel="external" href="http://www.rexdevelopment.org/">REX</a></li><li><a rel="external" href="http://www.theroofproject.org">ROOF</a></li><li><a rel="external" href="http://www.samact.org/about/loan_funds.shtml">SAMA</a></li><li><a rel="external" href="http://www.scrcog.org/">SCRCOG</a></li><li><a rel="external" href="http://www.southernct.edu/calendar/">SCSU Events</a></li><li><a rel="external" href="http://wflcenter.wordpress.com/">Share Our Voices</a></li><li><a rel="external" href="http://www.shubert.com">Shubert</a></li><li><a rel="external" href="http://www.solaryouth.com/">Solar Youth</a></li><li><a rel="external" href="http://freewebs.com/soul-o-ettes">Soul-O-Ettes</a></li><li><a rel="external" href="http://www.squashhaven.org/">Squash Haven</a></li><li><a rel="external" href="http://www.uwgnh.org">United Way</a></li><li><a rel="external" href="http://www.urbandesignleague.wordpress.com/">Urban Design League</a></li><li><a rel="external" href="http://www.urbanresourcesinitiative.org">Urban Resources Initiative</a></li><li><a rel="external" href="http://www.woostersquareblossom.blogspot.com/">W. Square Blossoms</a></li><li><a rel="external" href="http://www.rwater.com">Water Authority</a></li><li><a rel="external" href="http://westrocktrails.blogspot.com/">West Rock Trails</a></li><li><a rel="external" href="http://www.westvillect.org/">Westville Renaissance</a></li><li><a rel="external" href="http://www.westvilleshul.org">Westville Synagogue</a></li><li><a rel="external" href="https://www.facebook.com/groups/1466587933354636">What Now New Haven</a></li><li><a rel="external" href="http://www.woostersquarewatch.com">Wooster Sq. Watch</a></li><li><a rel="external" href="http://www.workforcealliance.biz">Workforce Alliance</a></li><li><a rel="external" href="http://events.yale.edu/opa/ChooseDate.jsp">Yale Events</a></li><li><a rel="external" href="http://www.cccymca.org/">YMCA</a></li><li><a rel="external" href="http://www.youthcontinuum.org">Youth Continuum</a></li></ul></div></div><div  id="ojp-content" class="content small-16 medium-12 large-10 columns" data-equalizer-watch="ie9"><div class="header-wrap row collapse"> <header class=" header small-16 columns"  role="banner"><div class="row"> <nav id="navable" class="navable__logged-out top-nav small-16 column"> <a class="menu-navlink hide-for-large-up" href="#main-menu"><span></span>menu</a> <a class="loggie" data-reveal-id="nhi-login" href="javascript:;" title="Login for New Haven Independent"  rel="loggin"><span></span>Login</a> <span class="evEnter"></span><div id="nhi-login" class="nhi-login reveal-modal" data-reveal aria-labelledby="nh_loginTitle" aria-hidden="true" role="dialog"><div id="ee_logform" class="loggin"><form id='loggin' method="post" action="https://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="9" /> <input type="hidden" name="RET" value="https://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/" /> <input type="hidden" name="site_id" value="3" /></div><fieldset><div class="row"><div class="large-16 columns logForm"><h4 id="nh_loginTitle" class="form-title">New Haven Independent Login Form</h4> <label for="username">username</label> <input type="text" name="username" value="" maxlength="32" class="input" size="20" /> <input class='checkbox' type='checkbox' name='auto_login' value='1' /> Auto-login on future visits</div></div><div class="row"><div class="large-16 columns logForm"><label for="password">password</label> <input type="password" name="password" value="" maxlength="32" class="input" size="20" /> <a href="http://www.newhavenindependent.org/index.php/participate/forgot_password/">Forgot your password?</a></div></div><div class="row"><div class="large-16 columns logForm"><button type="submit" name="submit" value="Submit" class="logan">submit</button></div></div></fieldset></form></div><a class="close-reveal-modal" aria-label="Close">&#215;</a></div><ul class="utility-menu sf-menu nav right show-for-medium-up"><li class="li_1"><span class="sf-with-ul">Info &amp; Contact</span><ul><li class="li_1"><span class="sf-with-ul">About</span><ul><li><a href="http://www.newhavenindependent.org/index.php/about_nhi/">New Haven Independent</a></li><li><a href="http://www.newhavenindependent.org/index.php/about_ojp/">Online Journalism Project</a></li></ul></li><li><a href="http://www.newhavenindependent.org/index.php/get_in_touch/">Contact</a></li><li><a href="http://www.newhavenindependent.org/index.php/site_policies/">Site Policies</a></li><li class="hide-for-large-up"><a href="http://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></li><li class="utility__donate show-for-large-up"><a href="http://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></nav></div><div id="upscroll" class="upscroll"><div class="nhi_hdr small-16 columns"><div class="branding small-16 medium-16 large-16" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="New Haven Independent"><a href="/">New Haven Independent</a></div></div></div><div class="row collapse"><nav id="secondary-nav" class="secondary-nav small-16 columns"> <nav id="seeAlso" class="secondary__seeAlso"> <a class="be_nav" href='https://www.newhavenindependent.org/index.php/branford/' title="Branford Eagle">Branford Eagle</a> <a class="vis_nav" href='https://valley.newhavenindependent.org' title="Valley Independent Sentinel">Valley Independent Sentinel</a> <a class="lv_nav" href="http://lavozhispanact.com/" title="La Voz Hispana">La Voz</a> </nav><div id="lookwrap" class="lookwrap"><form method="post" action="https://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="19" /> <input type="hidden" name="XID" value="" /> <input type="hidden" name="RP" value="search/results" /> <input type="hidden" name="NRP" value="" /> <input type="hidden" name="RES" value="" /> <input type="hidden" name="status" value="not closed|Pending" /> <input type="hidden" name="weblog" value="not sponsors" /> <input type="hidden" name="search_in" value="everywhere" /> <input type="hidden" name="where" value="all" /> <input type="hidden" name="site_id" value="3" /></div><div id="lookr" class="lookr row"><div class="search-box btn-group"><label for="keywords">Search:</label><input type="text" name="keywords" id="keywords" value="" placeholder="search New Haven Independent" class="search-field"  /><span class="clear-icon fa fa-times-circle"></span><button  class="submit search fa fa-search" type="submit" value="submit"><span>submit</span></button></div></div></form></div> </nav></div> <nav id="main-menu"  class="fin_nav nav"><ul><li class="mm-divider"><span>NHI Info &amp; Contact</span><ul id="fs_nav" class="nav"><li class="li_1"><span>About</span><ul><li><a href="https://www.newhavenindependent.org/index.php/about_nhi/">New Haven Independent</a></li><li><a href="https://www.newhavenindependent.org/index.php/about_ojp/">Online Journalism Project</a></li></ul></li><li><a href="https://www.newhavenindependent.org/index.php/get_in_touch/">Contact</a></li><li><a href="https://www.newhavenindependent.org/index.php/site_policies/">Site Policies</a></li><li><a href="https://www.newhavenindependent.org/index.php/donate/support_NHI/">Donate</a></li></ul></li><li class="mm-divider show-for-small-only"><a href="https://www.newhavenindependent.org/index.php/ee/P00/">Extra Extra</a></li><li class="mm-divider"><span>Sections</span><ul><li><a href="/index.php/archives/category/arts/">Arts & Culture</a><ul><li><a href="/index.php/archives/category/Crosswords/">Crosswords</a></li><li><a href="/index.php/archives/category/film/">Film</a></li><li><a href="/index.php/archives/category/funnies/">Op-Art</a></li><li><a href="/index.php/archives/category/music/">Music</a></li><li><a href="/index.php/archives/category/theater/">Theater</a></li><li><a href="/index.php/archives/category/tv/">TV/Radio</a></li></ul></li><li><a href="/index.php/archives/category/black_lives_matter/">Black Lives Matter</a></li><li><a href="/index.php/archives/category/businesslabor_economic_development/">Business/ Economic Development</a></li><li><a href="/index.php/archives/category/citizen_contributions/">Citizen Contributions</a></li><li><a href="/index.php/archives/category/city_hall/">City Hall</a></li><li><a href="/index.php/archives/category/environment/">Environment</a></li><li><a href="/index.php/archives/category/food/">Food</a></li><li><a href="/index.php/archives/category/gay_rights/">Gay Rights</a></li><li><a href="/index.php/archives/category/hamden/">Hamden</a></li><li><a href="/index.php/archives/category/healthcare/">Health</a></li><li><a href="/index.php/archives/category/higher_ed/">Higher Ed</a></li><li><a href="/index.php/archives/category/hometown_heroes/">Hometown Heroes</a></li><li><a href="/index.php/archives/category/housing/">Housing</a></li><li><a href="/index.php/archives/category/immigrant_tales/">Immigrants</a></li><li><a href="/index.php/archives/category/international/">International</a></li><li><a href="/index.php/archives/category/labor/">Labor</a></li><li><a href="/index.php/archives/category/legal_writes/">Legal Writes</a></li><li><a href="/index.php/archives/category/lgbtq/">LGBTQ</a></li><li><a href="/index.php/archives/category/media_books/">Media</a></li><li><a href="/index.php/archives/category/neighborhoods/">Neighborhoods</a></li><li><a href="/index.php/archives/category/opinion/">Opinion</a></li><li><a href="/index.php/archives/category/parks/">Parks</a></li><li><a href="/index.php/archives/category/politics/">Politics</a></li><li><a href="/index.php/archives/category/religion/">Religion</a></li><li><a href="/index.php/archives/category/schools/">Schools</a></li><li><a href="/index.php/archives/category/science_medical/">Science/ Medical</a></li><li><a href="/index.php/archives/category/serials/">Serials</a></li><li><a href="/index.php/archives/category/social_services/">Social Services</a></li><li><a href="/index.php/archives/category/sports/">Sports</a></li><li><a href="/index.php/archives/category/state/">State</a><ul><li><a href="/index.php/archives/category/2018_session/">2018 Session</a></li></ul></li><li><a href="/index.php/archives/category/transportation/">Transportation</a></li><li><a href="/index.php/archives/category/wnhh_radio/">WNHH Radio</a></li></ul></li><li class="mm-divider"><span>Neighborhoods</span><ul><li><a href="http://www.newhavenindependent.org/index.php/archives/category/amity/" title="Amity/ Beverly Hills">Amity/ Beverly Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/beaver_hills/" title="Beaver Hills">Beaver Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/bishop_woods/" title="Bishop Woods/ Q Meadows">Bishop Woods/ Q Meadows</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/cedar_hill/" title="Cedar Hill">Cedar Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/chatham_square/" title="Chatham Square">Chatham Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/city_point/" title="City Point">City Point</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/dixwell/" title="Dixwell">Dixwell</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/downtown/" title="Downtown">Downtown</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/dwight/" title="Dwight">Dwight</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/east_rock/" title="East Rock">East Rock</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/prospect_hill/" title="Prospect Hill">Prospect Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/edgewood/" title="Edgewood">Edgewood</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/fair_haven/" title="Fair Haven">Fair Haven</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/goatville/" title="Goatville">Goatville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/jocelyn_square/" title="Jocelyn Square">Jocelyn Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/kimberly_square/" title="Kimberly Square">Kimberly Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/long_wharf/" title="Long Wharf">Long Wharf</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/mill_river/" title="Mill River">Mill River</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/morris_cove/" title="Morris Cove">Morris Cove</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/newhallville/" title="Newhallville">Newhallville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/ninth_square/" title="Ninth Square">Ninth Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/quinnipiac_river_village/" title="Quinnipiac River Village">Quinnipiac River Village</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_annex/" title="The Annex">The Annex</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_heights/" title="The Heights">The Heights</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/the_hill/" title="The Hill">The Hill</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/trowbridge_square/" title="Trowbridge Square">Trowbridge Square</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/upper_state_street/" title="Upper State Street">Upper State Street</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_hills/" title="West Hills">West Hills</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_river/" title="West River">West River</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/west_rock/" title="West Rock">West Rock</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/westville/" title="Westville">Westville</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/whalley/" title="Whalley">Whalley</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/wooster_square/" title="Wooster Square">Wooster Square</a></li></ul></li><li class="mm-divider"><span>Features</span><ul><li><a href="https://www.newhavenindependent.org/index.php/archives/category/1_Day_3_Neighborhoods/" title="1 Day, 3 Neighborhoods">1 Day, 3 Neighborhoods</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/24_hours/" title="24 Hours">24 Hours</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2013/" title="Campaign 2013">Campaign 2013</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2017/" title="Campaign 2017">Campaign 2017</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/campaign_2018/" title="Campaign 2018">Campaign 2018</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/chef_of_the_week/" title="Chef Of The Week">Chef Of The Week</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/city_budget/" title="City Budget">City Budget</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/cop_of_the_week/" title="Cop of the Week">Cop of the Week</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/ct_bus_diaries/" title="CT Bus Diaries">CT Bus Diaries</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/jobs_pipeline/" title="Jobs Pipeline">Jobs Pipeline</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/news_from_the_pews/" title="News From The Pews">News From The Pews</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/prison_diary/" title="Prison Diaries">Prison Diaries</a></li><li><a href="https://www.newhavenindependent.org/index.php/archives/category/true_vote/" title="True Vote">True Vote</a></li></ul></li><li class="mm-divider mm-radio-menu"><span class="mm-wnhh-logo">WNHH Radio</span><ul><li class="e_84227"><a href="https://soundcloud.com/new-haven-independent/sets/book-talk-with-cyd-oppenheimer">Book Talk</a></li><li class="e_82732"><a href="https://soundcloud.com/new-haven-independent/sets/dateline-new-haven-season-3-0">Dateline New Haven</a></li><li class="e_84259"><a href="http://www.deepfocusradio.com/">Deep Focus</a></li><li class="e_85220"><a href="http://www.rdwolff.com/">Economic Update</a></li><li class="e_87184"><a href="https://soundcloud.com/new-haven-independent/sets/pundit-friday-season-2">Friday Pundits</a></li><li class="e_87356"><a href="http://www.uglyradio.net/Home/">Joe Ugly Show</a></li><li class="e_85223"><a href="https://soundcloud.com/new-haven-independent/sets/kicas-corner">Kica's Corner</a></li><li class="e_84263"><a href="https://soundcloud.com/new-haven-independent/sets/kitchen-sync-with-lucy-gellman">Kitchen Sync</a></li><li class="e_84262"><a href="https://soundcloud.com/new-haven-independent/sets/lovebabz-lovetalk">LoveBabz LoveTalk</a></li><li class="e_87185"><a href="http://www.newhavenindependent.org/index.php/archives/category/mayor_monday/">Mayor Monday!</a></li><li class="e_84001"><a href="https://soundcloud.com/new-haven-independent/sets/mornings-with-mubarakah">Mornings with Mubarakah</a></li><li class="e_84000"><a href="https://soundcloud.com/new-haven-independent/sets/northern-remedy">Northern Remedy</a></li><li class="e_83998"><a href="https://soundcloud.com/new-haven-independent/sets/michelles-turners-the-show">The Show</a></li><li class="e_90951"><a href="https://soundcloud.com/new-haven-independent/sets/the-table-underground">The Table Underground</a></li><li class="e_84260"><a href="https://soundcloud.com/new-haven-independent/sets/alisas-culture-cocktail">The Talk-Sip</a></li><li class="e_83995"><a href="https://soundcloud.com/new-haven-independent/sets/the-tom-ficklin-show">The Tom Ficklin Show</a></li></ul></li><li class="mm-divider"><span>Legal Notices</span><ul><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aascc_legal_notices/" title="Agency On Aging">Agency On Aging</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/aldermen/" title="Board of Alders">Board of Alders</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/housing_authority/" title="Housing Authority">Housing Authority</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/public_meetings/" title="City Clerk">City Clerk</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/other/" title="Other">Other</a></li><li><a href="http://www.newhavenindependent.org/index.php/archives/category/probate_court/" title="Probate">Probate</a></li></ul></li><li class="mm-multiline mm-divider"><span>Government/ Community Links</span><ul class="linklist"><li><a rel="external" href="http://www.rkidsct.org/">&#8216;r Kids Family Center</a></li><li><a rel="external" href="https://www.onecityinitiative.org/">1 City/ 60 Days</a></li><li><a rel="external" href="http://www.aoascc.org/">Agency on Aging</a></li><li><a rel="external" href="http://www.apnh.org">AIDS Project NH</a></li><li><a rel="external" href="http://www.traumainformedschools.org">ALIVE</a></li><li><a rel="external" href="http://www.allourkin.org">All Our Kin</a></li><li><a rel="external" href="http://www.findafriendforlife.org">Animal Shelter Volunteers</a></li><li><a rel="external" href="http://www.arte-inc.com">Arte Inc.</a></li><li><a rel="external" href="http://www.newhavenarts.org">Arts Council</a></li><li><a rel="external" href="http://www.artsinct.org">Arts In CT</a></li><li><a rel="external" href="http://artspacenh.org">Artspace</a></li><li><a rel="external" href="http://www.beki.org">Beth El Keser Israel</a></li><li><a rel="external" href="http://www.bbbsswct.org">Big Brothers Big Sisters</a></li><li><a rel="external" href="https://bikenewhaven.wordpress.com/">Bike New Haven</a></li><li><a rel="external" href="http://www.bgcnewhaven.org">Boys &amp; Girls Club</a></li><li><a rel="external" href="http://www.cancersupportcommunitysct.org">Cancer Support</a></li><li><a rel="external" href="http://www.WestvilleChabad.com">Chabad of Westville</a></li><li><a rel="external" href="http://www.gnhcc.com">Chamber of Commerce</a></li><li><a rel="external" href="http://www.childrensbuilding.org/">Children&#8217;s Museum</a></li><li><a rel="external" href="http://www.ccahelping.org/">Christian Community Action</a></li><li><a rel="external" href="http://www.cityofnewhaven.com">City of New Haven</a></li><li><a rel="external" href="http://www.cityseed.org/">CitySeed</a></li><li><a rel="external" href="http://www.cwyc.org">Citywide Youth</a></li><li><a rel="external" href="http://www.columbushouse.org">Columbus House</a></li><li><a rel="external" href="http://www.caanh.net/">Community Action Agency</a></li><li><a rel="external" href="http://www.gnhclf.org">Community Loan Fund</a></li><li><a rel="external" href="http://www.community-mediation.org">Community Mediation</a></li><li><a rel="external" href="http://www.conncan.org/matriarch/default.asp">ConnCAN</a></li><li><a rel="external" href="http://www.cornellscott.org">Cornell Scott&#8212;Hill Health Center</a></li><li><a rel="external" href="http://www.creativeartsworkshop.org/">Creative Arts Workshop</a></li><li><a rel="external" href="http://www.connecticut.baeo.org">CT BAEO</a></li><li><a rel="external" href="http://www.ctbestrestaurants.com/">CT Best Restaurants</a></li><li><a rel="external" href="http://www.ct.org/">CT Tech Council</a></li><li><a rel="external" href="http://www.ctdatahaven.org">Data Haven</a></li><li><a rel="external" href="http://www.ecoworksct.org">EcoWorks</a></li><li><a rel="external" href="http://groups.yahoo.com/group/elmcitycycling/">Elm City Cycling</a></li><li><a rel="external" href="http://www.elmshakespeare.org">Elm Shakespeare</a></li><li><a rel="external" href="http://www.elmseed.org">Elmseed</a></li><li><a rel="external" href="http://www.empowernewhaven.org">Empower NH</a></li><li><a rel="external" href="http://www.friendsofwoostersquare.org/">Friends Of Wooster Sq.</a></li><li><a rel="external" href="http://www.grandnewhaven.com">GAVA</a></li><li><a rel="external" href="http://www.ctgmc.org/">Gay Men&#8217;s Chorus</a></li><li><a rel="external" href="http://www.gnhcc.org">GNH Community Chorus</a></li><li><a rel="external" href="http://www.habitatgnh.org">Habitat For Humanity</a></li><li><a rel="external" href="http://www.historicwoostersquare.org/">Historic Wooster Sq. Assn.</a></li><li><a rel="external" href="http://www.infonewhaven.com">Info New Haven</a></li><li><a rel="external" href="http://www.infonewhaven.com/calendar">INFO NH Calendar</a></li><li><a rel="external" href="http://www.irisct.org">IRIS</a></li><li><a rel="external" href="http://jazzhaven.org">Jazz Haven</a></li><li><a rel="external" href="http://www.jewishnewhaven.org">Jewish Federation</a></li><li><a rel="external" href="http://NewHavenCountyJobs.com">Job Finder</a></li><li><a rel="external" href="http://www.juntainc.org/">Junta</a></li><li><a rel="external" href="http://www.laborhistory.org/">Labor History</a></li><li><a rel="external" href="http://www.newhavenfindalawyer.org">Lawyer Finder</a></li><li><a rel="external" href="http://www.leapforkids.org">LEAP</a></li><li><a rel="external" href="http://www.ctnla.org/">Legal Aid Network</a></li><li><a rel="external" href="http://www.libertycs.org">Liberty Safe Haven</a></li><li><a rel="external" href="http://www.lifehaven.org/">Life Haven</a></li><li><a rel="external" href="http://www.literacyeveryday.org">Literacy Coalition</a></li><li><a rel="external" href="http://www.magrissoforte.com">Magrisso Forte</a></li><li><a rel="external" href="http://www.marywade.org/">Mary Wade</a></li><li><a rel="external" href="http://www.musichavenct.org">Music Haven</a></li><li><a rel="external" href="http://www.neighborhoodmusicschool.org/">Neighborhood Music School</a></li><li><a rel="external" href="http://newhaven828.typepad.com/828/">New Haven 828</a></li><li><a rel="external" href="http://www.newhavenchorale.org/">New Haven Chorale</a></li><li><a rel="external" href="http://www.newhavenfarms.org/">New Haven Farms</a></li><li><a rel="external" href="http://www.newhavenmuseum.org">New Haven Museum</a></li><li><a rel="external" href="http://www.newhavenreads.org/">New Haven Reads</a></li><li><a rel="external" href="http://www.newlifecorp.org">New Life Corp.</a></li><li><a rel="external" href="http://www.newreach.org">New Reach</a></li><li><a rel="external" href="http://www.newhavenbirdclub.com">NH Bird Club</a></li><li><a rel="external" href="http://www.newhavenlandtrust.org">NH Land Trust</a></li><li><a rel="external" href="http://www.newhavensymphony.org">NH Symphony</a></li><li><a rel="external" href="http://www.newhavenleon.org">NH/Leon Sister City</a></li><li><a rel="external" href="http://www.nhsofnewhaven.org">NHS</a></li><li><a rel="external" href="http://ontheroadtogreenness.blogspot.com/">On The Road To Greenness</a></li><li><a rel="external" href="http://www.orchardstreetshul.org/">Orchard Street Shul</a></li><li><a rel="external" href="http://www.orchestranewengland.org">Orchestra NE</a></li><li><a rel="external" href="http://www.pathct.org">Parents Available to Help</a></li><li><a rel="external" href="http://www.housedems.ct.gov/Dillon/index.asp">Pat Dillon</a></li><li><a rel="external" href="http://peacenews.org">Peace News</a></li><li><a rel="external" href="http://www.PKN-NewHaven.Org">PechaKucha</a></li><li><a rel="external" href="http://www.ppsne.org">Planned Parenthood</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/Police/index.asp">Police</a></li><li><a rel="external" href="http://par-newhaven.org/">Progressive Action Roundtable</a></li><li><a rel="external" href="http://www.pepeace.org">Promoting Enduring Peace</a></li><li><a rel="external" href="http://www.publicallies.org">Public Allies CT</a></li><li><a rel="external" href="http://www.nhfpl.org/services/community">Public Library</a></li><li><a rel="external" href="http://www.nhps.net">Public Schools</a></li><li><a rel="external" href="http://www.cityofnewhaven.com/PublicWorks/index.asp">Public Works</a></li><li><a rel="external" href="http://www.ctiorg.org/">Rainbow Girls</a></li><li><a rel="external" href="http://entertainment.ctcentral.com/html/index.php">Register Calendar</a></li><li><a rel="external" href="http://www.rexdevelopment.org/">REX</a></li><li><a rel="external" href="http://www.theroofproject.org">ROOF</a></li><li><a rel="external" href="http://www.samact.org/about/loan_funds.shtml">SAMA</a></li><li><a rel="external" href="http://www.scrcog.org/">SCRCOG</a></li><li><a rel="external" href="http://www.southernct.edu/calendar/">SCSU Events</a></li><li><a rel="external" href="http://wflcenter.wordpress.com/">Share Our Voices</a></li><li><a rel="external" href="http://www.shubert.com">Shubert</a></li><li><a rel="external" href="http://www.solaryouth.com/">Solar Youth</a></li><li><a rel="external" href="http://freewebs.com/soul-o-ettes">Soul-O-Ettes</a></li><li><a rel="external" href="http://www.squashhaven.org/">Squash Haven</a></li><li><a rel="external" href="http://www.uwgnh.org">United Way</a></li><li><a rel="external" href="http://www.urbandesignleague.wordpress.com/">Urban Design League</a></li><li><a rel="external" href="http://www.urbanresourcesinitiative.org">Urban Resources Initiative</a></li><li><a rel="external" href="http://www.woostersquareblossom.blogspot.com/">W. Square Blossoms</a></li><li><a rel="external" href="http://www.rwater.com">Water Authority</a></li><li><a rel="external" href="http://westrocktrails.blogspot.com/">West Rock Trails</a></li><li><a rel="external" href="http://www.westvillect.org/">Westville Renaissance</a></li><li><a rel="external" href="http://www.westvilleshul.org">Westville Synagogue</a></li><li><a rel="external" href="https://www.facebook.com/groups/1466587933354636">What Now New Haven</a></li><li><a rel="external" href="http://www.woostersquarewatch.com">Wooster Sq. Watch</a></li><li><a rel="external" href="http://www.workforcealliance.biz">Workforce Alliance</a></li><li><a rel="external" href="http://events.yale.edu/opa/ChooseDate.jsp">Yale Events</a></li><li><a rel="external" href="http://www.cccymca.org/">YMCA</a></li><li><a rel="external" href="http://www.youthcontinuum.org">Youth Continuum</a></li></ul></li></ul></nav> </header></div><div class="row ctr-wrap" data-equalizer="ctr" data-equalizer-mq="medium-up" data-equalizer-watch="ie9"><div id="ctr" class="entry-ctr small-16 columns"><meta itemscope itemprop="mainEntityOfPage" itemid="https://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/"/><h1 class="entry-title" itemprop="headline">Post-Death, Henry Green’s Story Continues</h1><p class="posted entry__info" itemprop="author" itemscope itemtype="https://schema.org/Person">by <span class="auth entry-author-name" itemprop="name"> David Sepulveda</span> |  Aug 21, 2018  3:44&nbsp;pm</p><p class="spec_list entry__info"> <a href="#p_cmt">Post a Comment</a> | <a href="#e_auth"   data-reveal-id="e_auth" title="E-mail the Author">E-mail the Author</a></p><p class="p_cat entry__info">Posted to: <a href="https://www.newhavenindependent.org/index.php/archives/category/arts/">Arts & Culture</a>, <a href="https://www.newhavenindependent.org/index.php/archives/category/hometown_heroes/">Hometown Heroes</a>, <a href="https://www.newhavenindependent.org/index.php/archives/category/newhallville/">Newhallville</a></p><div id="entryCtr" class="entry-content" itemprop="articleBody"><meta itemprop="datePublished" content="2018-08-21T15:44:21-0400"/><meta itemprop="dateModified" content="2018-08-21T17:19:22-0400"/><p> <img class="imgcaption wDefault" src="/images/made/archives/upload/2018/08/David/David-Henroles-Screenshot_2018-08-19_07.04.58_690_914_88_sha-100.jpg" itemprop="thumbnailUrl" width="690" height="914" title="Green in some of his stage roles." alt="Courtesy of Robert Esposito" />A bullet that pierced Henry Harris Green IV, aka Renegade, on a Newhallville street eight years ago, and remained lodged in his body is now evidence in an investigation into his recent death.</p><p>Call it one more chapter in a compelling story about a young man who embraced life against great odds while injecting humanity into the communal conversation about gun violence.</p><p>Green, a celebrated actor and motivational speaker whose turned-around life became the subject of a documentary, died of medical complications at age 26, in a Washington, D. C. hospital on July 22.</p><p>A month after his death, the story continues.</p><p>That life will be remembered and celebrated this Thursday beginning  at 11 a.m. at Vertical Church, 225 Meloy Rd., in West Haven. All are welcomed to attend. Green&#8217;s family has launched <a href="https://www.freefunder.com/campaign/hope-fund--medicl--reltd-exp">this GoFundMe page</a> to help defray medical and funeral-related expenses.</p><p>And family members and friends opened up in recent interviews about the deep impact Green made on New Haven in his short yet rich life.</p><p>Meanwhile, Assistant Police Chief Herb Johnson confirmed that the police are taking a second look at the 2009 shooting that caused the injuries that eventually led to Green&#8217;s death last month. (Johnson declined to discuss specifics of the pending investigation.)</p><p>The bullet that almost killed Green back then never left his body. When his body was cremated, police preserved the bullet, to be used in a revived potential homicide investigation, according to the family.</p><p>The bullet eventually killed him, but not before Green figured out how to turn his personal tragedy into an inspirational tale of embracing life.</p><h5>&#8220;God Punched Me In The Stomach&#8221;</h5><p> <img class="imgcaption wDefault lazy"  src="/images/made/assets/img/ojp_fill_720_885_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David-_Role_of_Jesus-IMG_5527_720_885_88_sha-100.jpg"  width="720" height="885" title="Green in Lead role of <i>Jesus Christ Superstar</i> at Co-op." alt="ROB ESPOSITO PHOTO" /><noscript> <img src="/images/made/archives/upload/2018/08/David/David-_Role_of_Jesus-IMG_5527_720_885_88_sha-100.jpg" itemprop="image" alt="Green in Lead role of <i>Jesus Christ Superstar</i> at Co-op." width="720" height="885" data-credit="ROB ESPOSITO PHOTO" /></noscript>Green’s miraculous recovery from the shooting, owing in part to a rare intestinal transplant that tested medical ingenuity and resolve, was only the beginning of an odyssey of recovery and setbacks. His medical journey was followed by loved ones, friends, and a diverse and broad community, who were shocked by the tragedy of his shooting, but buoyed by Green’s determination to make good use of his second chance at life.&nbsp;</p><p>Green was an honors student at Cooperative Arts &amp; Humanities High School. He acted in plays, including in Shakespeare in the Park at Edgerton Park.</p><p>According to Robert Esposito, Green’s theater teacher at Cooperative Arts and Humanities High School, Green as an actor and student was an all-time standout: “Henry touched so many lives in such a profound way. He had physical height but also there was the height of his charisma. I’ve never had a student like him —intellectual and with street smarts.”</p><p>Esposito said that Green’s attendance at a five-week program away from New Haven at the Center for Creative Youth was a turning point.&nbsp; “It was a period where he had to decide if he was going to be a gang leader or an artist… ‘In order to be a lead in a play, you also have to be a leader,’” he recalled telling Green.</p><p>“Henry will always be remembered as a bright-eyed, idealistic, intelligent man — a model of a Renaissance man who could talk to anybody… With a high EQ  [emotional intelligence], had Henry been a therapist, he would be $500 per hour. He could intuit and sense what people were feeling.”</p><p>Esposito also noted that Green deserved every role he ever played in high school  —&nbsp; and there were many, including Jesus in the rock opera <em>Jesus Christ Superstar</em>. That performance earned high praise from New Haven Advocate theater critic Christopher Arnott, even as the reviewer found serious issues with the professional, touring presentation of the same play, staged simultaneously at Shubert Theater, only a block away from Co-op.</p><p>“I’d never heard Henry speak angrily or disrespect someone, or be gossipy. Henry was a Christian that acted like Christ — he lived the spirit of who Christ was,” said Esposito.</p><p><span class="arc90_img vdo floatl" style="width: 75%;"><iframe width="540" height="405" src="https://www.youtube.com/embed/pwgP6OSFKJE?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></span>Back home in Newhallville, Green also hung out with gang members. &#8220;In the project nobody wants you to sing a musical number,&#8221; he recalled in a video interview about his shooting (above). &#8220;Nobody cares. ... Getting on the city bus, I&#8217;m on the ugly cracked sidewalk, I had no power left. I went form being a king to being a peasant real fast. &#8216;Henry Green&#8217; held no weight on the street. The only thing I could do that made me feel any security or safety if people were as afraid of me as I was afraid of them.&#8221;</p><p>Here&#8217;s how he described his shooting in the video interview:</p><p>&#8220;The day that I was shot, I was coming home from work. I was with one of my boys, a nice kid. I meet him, coming off the bus, as we usually do. As we were walking toward my house on Shelton Avenue, there are four kids. They have the ski masks, the hoodies. You know they&#8217;re robbing people. If they select you, if you become a target, you&#8217;re getting beat, or shot, or stabbed.</p><p>&#8220;I start walking, trying to keep my cool. I start walking faster. I tell my boy, &#8216;Listen, you need to run.&#8217; My boy takes off.</p><p>&#8220;These kids, they walk up to me. A small kid, he had to be between 14 and 16, whips out this 9, point blank. &#8216;Yo, give me me everything you got.&#8217; He puts the gun right on my stomach.</p><p>&#8220;I had no power. I had no security. It made my mad. I did not want to give him anything. I barely had anything. Neither one of us got no money; we live on the same street probably.</p><p>&#8220;I crossed my arm. &#8216;I&#8217;m not giving you nothing.&#8217;</p><p>&#8220;This kid keeps egging me on. I look inside his face; this kid is fighting for that sense of security I&#8217;m trying to hold onto. I look into his eyes; he&#8217;s a scared little kid. He wants to be important like these guys behind him. In his eyes I could see he was begging, &#8216;Please give me this sense of power. I need this. I don&#8217;t have anything else. I need to take this from you, or I&#8217;m leaving you with nothing.&#8217;</p><p>&#8220;People don&#8217;t kill for sneakers. People don&#8217;t kill for change. People don&#8217;t kill for a girl. They kill to have power.</p><p>&#8220;Next thing I know he shot me. <em>Boom! Boom boom boom!</em> It blew my ears out. These kids run; they take off. I stumble to the ground. It felt like God punched me in the stomach. Like God snuffed me. It hurt. I lay myself down. I feel myself bleeding.Warm liquid was running down my leg. So I take out my phone. I call 911 myself. Nobody in New Haven really calls the cops when someone shoots somebody else. I lay on the sidewalk, bleeding out on Shelton Avenue, like so many other people have.&#8221;</p><h5>A 2nd Shot At Life</h5><p> <img class="imgcaption wHalf lazy"  src="/images/made/assets/img/ojp_fill_360_540_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David-Gym-2015-12-15_05.01.24_360_540_86_sha-100.jpg" itemprop="image" width="360" height="540" title="Green trains after Intestinal transplant." alt="" />The first hours after the shooting were tenuous for Green, at best.</p><p>“Henry was transfused with 42 units of blood — seven times the normal body capacity,” according to mom Linda Marks&#8217; calculation. “He actually died that night; doctors were able to bring him back and save his life, but the iIliac artery, which supplies  the small intestine, was destroyed in the shooting and eventually the small intestine died too.”</p><p>Specific medical information gleaned from doctors was especially helpful to Marks in her spiritual interventions for her son over the course of his long battle: “I would know how to direct my prayers,” tailoring prayers to specific medical needs. “It was an impossible situation and people were praying all over the world. Henry’s pastor at the time, Pastor Todd [Foster], placed prayer requests for Henry on an international prayer list,&#8221; she said.</p><p>When Green awoke later on in the hospital, needing a machine to breathe, he decided he had to forgive his shooter, he said. &#8220;Because I had to forgive myself.&#8221;</p><p>Green’s medical fortunes took a turn for the better while living precariously without a small intestine when a donor intestine became available for transplant. Green immediately made the trip went to Washington, D.C., where he stayed for six months as doctors monitored his progress in the wake of the unusual, if not rare transplant procedure. It would be the first of many trips Green would make over the ensuing years as he worked to keep up with the medical demands of living with the transplanted organ.</p><p>With the first transplant operation behind him, Green began to heal. He could often be found at the gym where his regiment of weight training would strengthen and transform his musculature, but also exercise his will to exceed medical expectations.&nbsp;</p><p>Meanwhile, Green was working for New Haven&#8217;s <a href="https://www.newhavenindependent.org/index.php/archives/entry/conncat_cafe_ConnCAT_jobs/">Connecticut Center for Arts</a> and <a href="https://www.newhavenindependent.org/index.php/archives/entry/keybank_to_conncat/">Technology (ConnCAT) </a>and its stated mission to “inspire, motivate, and prepare youth and adults for educational and career advancement, through after-school arts, and job training programming.” At ConnCAT, Green was a spoken word instructor teaching high school and middle school students the art of creating hip hop beats, freestyling and some studio production techniques.</p><p>In addition to mentoring students at ConnCAT, Green found time to work with the Department of Children and Families (DCF). Alongside probation officers Green, using his own life experience as exhibit A, spoke with gang members and youthful offenders in an effort to help turn their lives around. Part of Green’s outreach and engagement also included a stint talking with Veterans who were experiencing Post Traumatic Stress Disorder.</p><p>Green and family members and friends formed a motivational group, dubbing the initiative <a href="https://www.newhavenindependent.org/index.php/archives/entry/henry_green_group/">“Worldwide”</a> as early as 2011. Providing workshops that emphasized hip hop-centric lyrics and music, the group reached young audiences in churches and schools with positive messages of empowerment.</p><p><span class="arc90_img vdo floatl" style="width: 75%;"><iframe width="540" height="304" src="https://www.youtube.com/embed/2zYU1fxEjfI?start=1&feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></span>In an original spoken word piece entitled “Confliction,” presented at the Boys and Girls Club of New Haven and several other venues in 2016, Green and his brother, Solomon, provided an autobiographical glimpse into coping with the psychological intricacies of street life and the politics of turf boundaries that often place not-so-dissimilar individuals at odds with one another. (Watch it in the above video.)</p><h5>The Movie</h5><p></p><p> <img class="imgcaption wDefault lazy"  src="/images/made/assets/img/ojp_fill_720_410_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David-_I_am-31964066_1644028652378381_742794029539786752_n_720_410_88_sha-100.jpg"  width="720" height="410" title="Graphic promo for the movie." alt="" /><noscript> <img src="/images/made/archives/upload/2018/08/David/David-_I_am-31964066_1644028652378381_742794029539786752_n_720_410_88_sha-100.jpg" itemprop="image" alt="Graphic promo for the movie." width="720" height="410" data-credit="" /></noscript>Several years after Green’s initial recovery from the shooting, Green was approached by fllmmaker Stephen Dest with his idea of <a href="https://www.newhavenindependent.org/index.php/archives/entry/henry_green_story_takes_center_stag/">doing a film</a>.</p><p>At first unsure, Green later came to realize that, like much of the community work he was already doing, the film stood to help others. The original concept for the film was for a drama with a cast of actors, but ultimately evolved into documentary format and an unusual cinematic device in which the weight of the film rests primarily on Green’s immense talent as storyteller. Green commands viewer focus throughout the film  —&nbsp; frame, by frame, loosing the demons of his past, exposing his innermost fears and concerns.</p><p>Dest said that <a href="https://www.newhavenindependent.org/index.php/archives/entry/new_film_will_tell_henry_green_story/">doing the film</a> had been therapeutic for Green, giving  him a “sense of comfort and closure.”</p><p> <img class="imgcaption wHalf lazy"  src="/images/made/assets/img/ojp_fill_360_540_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David--Actor-director-MG_7157_360_540_86_sha-100.jpg" itemprop="image" width="360" height="540" title="Green and Dest before filming." alt="" />The film may also have therapeutic and social value for viewers seeking answers to the violence plaguing communities nationally. In local screenings, it has already  prompted <a href="https://www.newhavenindependent.org/index.php/archives/entry/i_am_shakespeare_1/">candid discussions among audiences from neighborhoods </a> to film festivals, to a screening for 150 incoming Yale School of Medicine residents, generating a companion <a href="http://www.ctschoolchange.org/wp-content/uploads/I-Am-Shakespeare-Facilitation-Guide.pdf ">screening facilitation guide</a> which is available through <a href="http://www.ctschoolchange.org/">Connecticut Center for School Change </a>.</p><p>The guide provides this synopsis of the film: “It is a story about the tension that exists in a community when an impoverished neighborhood dominated by gangs and plagued by gun violence is in the shadow of one of the country’s wealthiest universities. It is about the complexity of identity, and the struggle for pride and self-worth. It is about suffering trauma, receiving salvation, and offering forgiveness. It is a story about hope.”</p><p>Linda Marks, Green&#8217;s mother, noted other dimensions of his life that were not the focus of the film and often missed in narratives about his life.</p><p>Green and his siblings, Jamillah Green, Jamaahl, Kevin Green, Cynthia, and Solomon, were raised in the church, New Haven&#8217;s Church of the Rock and later West Haven&#8217;s Vertical Church. Marks, who was divorced, did her best to provide for the family with some monetary support from Green’s father.&nbsp; She said that for a short while, she was on assistance, but later found full time employment and managed to provide a home sanctuary for her family even as she worked to educate herself and see that her children remained on a trajectory of advancement. She recalled that at one point, the whole family was in college in one form or another.</p><p><span class="arc90_img vdo floatl" style="width: 75%;"><iframe width="540" height="304" src="https://www.youtube.com/embed/lBuq7JL2fbY?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></span>Marks attended Southern Connecticut State University graduating with a B.S. degree in Business Administration, and afterward, attended Lincoln Technical Institute Vocational School graduating with nursing certification.&nbsp; Her tenacity sometimes included bringing her children with to her with to her college classes when she was unable to secure a baby sitter, an arrangement that professors accommodated.“My hard work, tenacity and willingness to try new things taught my children that anything is possible if you’re willing to put the time and effort into it,&#8221; she said.</p><h5>Higher Heights</h5><p> <img class="imgcaption wDefault lazy"  src="/images/made/assets/img/ojp_fill_720_1079_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David-Engagedand_2014-IMG_7163_720_1079_88_sha-100.jpg"  width="720" height="1079" title="Daviya  and Henry." alt="" /><noscript> <img src="/images/made/archives/upload/2018/08/David/David-Engagedand_2014-IMG_7163_720_1079_88_sha-100.jpg" itemprop="image" alt="Daviya  and Henry." width="720" height="1079" data-credit="" /></noscript>Daviya Green met Henry Green in the church they both attended. They later married in 2014.</p><p>“Henry lived with contradictions,&#8221; she recalled. &#8220;He wasn’t a hard core gangbanger… He was always a principled person. Henry was the hood, Robin Hood; he would stand up for anyone who needed help.”</p><p>At the beginning of 2017 Green’s external life seemed to be coming together. He graduated with a bachelor of science degree in psychology from Charter Oak State College’s online program. He was poised to receive a raise at his job as a social worker teaching social skills to kids at Family Centered Services in New Haven.&nbsp;</p><p>Following the second transplant, Green seemed to recover quickly. His resilience and determination, the prayers and support of family and friends converged with innovative medical procedures to buy him additional time.</p><p>But it would not be long before new signs of trouble began to emerge. His kidneys and liver began to show signs of rejection; lymphoma (cancer) made an appearance to add to the woes of his embattled immune system.</p><p>In March of this year Green went in for a check-up following symptoms related to his kidneys. The visit would require an overnight stay; the day turned into weeks as complications began to mount. Green contracted a bacterial blood infection called PTLD, one of the growing list of medical acronyms with which the Green family would become familiar.</p><p>He also suffered repeating bouts of pneumonia. For the next few months Green was in and out of intensive care while also receiving kidney dialysis.</p><p> <img class="imgcaption wDefault lazy"  src="/images/made/assets/img/ojp_fill_720_480_c1.gif" data-src="/images/made/archives/upload/2018/08/David/David-_Hen_in_Gym-2015-12-15_04.54.37_720_480_88_sha-100.jpg"  width="720" height="480" title="Daviya Green, far left, by Green&#8217;s side in the gym." alt="" /><noscript> <img src="/images/made/archives/upload/2018/08/David/David-_Hen_in_Gym-2015-12-15_04.54.37_720_480_88_sha-100.jpg" itemprop="image" alt="Daviya Green, far left, by Green&#8217;s side in the gym." width="720" height="480" data-credit="" /></noscript>The hospital was in Washington, D.C. where Daviya made periodic trips to be with her husband. “It was expensive but I had to be there for my husband/ he was my best friend” she said.</p><p>Daviya received a call from doctors one evening to come to Washington— immediately, if she could. Green’s blood pressure had dropped precipitously. They were concerned that he would not make it through the night.</p><p>Buoyed by gospel music as she drove to D.C., fighting to see the road through a steady flow of tears, Daviya was delayed two flat tires and the cost of their replacement. which she could ill afford.</p><p>At the hospital, facing her still-conscious husband whose communication was hampered by an assortment of tubes and devices, Daviya told Green she loved him/ She told him that everything was going to be OK.</p><p>She asked him if he was afraid. Green shook his head “no.”</p><p>Those would be among the last words she would speak to her husband before his death two nights later.&nbsp; “With so many things left for Henry to do,” said Daviya, “it was hard to pray for God’s will to be done.”&nbsp;</p><p>Daviya expressed her gratitude for having been married to Henry Green: “He cared for me like nobody could. He was serious about taking care of me, a protector.&nbsp; He was serious about the people he cared for.“&nbsp;  The young widow reluctantly allowed herself a momentary, wistful thought: “With a size 15 shoe, any man in my future will have big shoes to fill, literally and figuratively.”&nbsp;</p><p>In 2018, Henry Green’s name has been added to the numbing, annual statistics associated with gun violence in this nation. The impact of his life, however, will transcend statistics. His message  &#8212;&nbsp; “Violence is definitely preventable”&nbsp; &#8212;&nbsp; will resonate with all who knew him, and with many more who did not.&nbsp;</p></div> <img class="no" src='https://www.newhavenindependent.org/index.php?ACT=113&amp;vars=YToyOntzOjg6ImVudHJ5X2lkIjtzOjY6IjEwNjg2NCI7czo5OiJ3ZWJsb2dfaWQiO3M6MjoiMTAiO30=' /><h4 class="tagList">Tags: <a rel="tag" href="https://www.newhavenindependent.org/index.php/archives/taglist/Henry_Green">Henry Green</a>, <a rel="tag" href="https://www.newhavenindependent.org/index.php/archives/taglist/second_chances">second chances</a></h4><div id="e_auth" class="e_auth reveal-modal" data-reveal aria-labelledby="nh_emailAuthorTitle" aria-hidden="true" role="dialog" style="display: none;"><form id='contact_form' method="post" action="https://www.newhavenindependent.org/index.php"  ><div class='hiddenFields'> <input type="hidden" name="ACT" value="20" /> <input type="hidden" name="RET" value="" /> <input type="hidden" name="URI" value="/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/" /> <input type="hidden" name="recipients" value="1+tq6FTEn1O9OcR88yJdRv5RfMYEQDK3U/jd5t7jb1c=" /> <input type="hidden" name="user_recipients" value="7a44810c6a31cd13c20d2554443c0c5e" /> <input type="hidden" name="charset" value="utf-8" /> <input type="hidden" name="redirect" value="" /> <input type="hidden" name="replyto" value="" /> <input type="hidden" name="site_id" value="3" /></div><input type="hidden" name="to" size="40" value="dsepulveda.sepulveda@gmail.com" readonly /><p><label for="from">Your Email:</label><br /> <input type="text" id="from" name="from" size="60" maxlength="45" value=""/></p><p><label for="subject">Subject:</label><br /> <input type="text" id="subject" name="subject" size="60" value="Contact David Sepulveda Re:Post-Death, Henry Green’s Story Continues" readonly /></p><p><label for="message">Message:</label><br /><textarea id="message" name="message" rows="18" cols="40">
Sent: Aug 21, 2018  5:26 pm</textarea></p><p>Please enter the word you see in the image below:</p><p><img src="https://events.newhavenindependent.org/images/captchas/1534886789.5549.jpg" width="140" height="30" style="border:0;" alt=" " /><br /> <input type="text" name="captcha" value="" maxlength="20" /></p><p><button type="submit" name="submit" value="Submit Form" class="logan">submit</button></p> <a class="close-reveal-modal" aria-label="Close">&#215;</a></form></div><div id="share" class="share"><p class="socB">Share this story with others.</p><div class="addthis_inline_share_toolbox_msqo_xojq" addthis:url="https://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/" addthis:title="Post-Death, Henry Green’s Story Continues"></div><p id="facebook_like"></p></div><h3 id="p_cmt">Post a Comment</h3><h4>You must be logged in to comment</h4><p><strong>If you already have an account</strong>, please <a class="btn" href="javascript:;" data-reveal-id="nhi-login">log in here</a> | If not, please <span class="evEnter"></span>.</p><h3 id="cmt">Comments</h3><div class="cmt_body"><p>Be the first to comment</p></div> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f2021f347757e15" async></script> <script type="text/javascript" language="javascript" defer>jQuery(document).ready(function() {
jQuery('#facebook_like').socialbutton('facebook_like', {
    button: 'standard',
    url: 'https://www.newhavenindependent.org/index.php/archives/entry/henry_greens_life_and_legacy_to_be_celebrated/',
    encoded: true,
    show_faces: false,
    width: 550,
    height: 20,
    action: 'recommend',
    colorscheme: 'light'
});
});</script> </div></div></div><div id="farRight" class="far-right mm-pageshadow ie9-hfix hide-for-print medium-4 large-3 column" data-equalizer-watch="ie9"> <section class="inner-wrap" data-navigation-handle=".toggle-panel" data-navigation-content=".content" > <aside class="this-maybe"><h3 id="e_Cal" class="e_cal"><a href="http://events.newhavenindependent.org/">Events Calendar</a></h3><div id="eventCal" class="eventCal nh_sidecal lazy" data-src="/events/index.php/calendar/nhi_cal_sidebar/"><p id="calloading" class="calloading">loading…</p></div><h3 id="scf" class="scf"><a href="http://www.seeclickfix.com/new-haven" target="_blank">SeeClickFix &raquo;</a></h3><div id="seeclickfix" class="seeclickfix  c_event"><dl class="vevent"><dt class="summary"><a href="https://seeclickfix.com/issues/3920910">Tree Trimming</a></dt><dd class="sched dtstart">Dec 1, 2017 12:18 pm</dd><dd class="description">Address: 213 Maple St New Haven, Connecticut Rating: 1</dd></dl><dl class="vevent"><dt class="summary"><a href="https://seeclickfix.com/issues/3920867">(EONP)11 Huntington Ave.</a></dt><dd class="sched dtstart">Dec 1, 2017 12:02 pm</dd><dd class="description">Address: 11 Huntington Ave New Haven, CT 06512, USA Rating: 1</dd></dl></div><h3 id="nhi_bb" class="nhi_bb">PosterWall<a href="//www.newhavenindependent.org/index.php/posterwall/">Add your Poster</a></h3><div id="ojp-bb-tv" class="bb lazy" data-src="https://truevote.newhavenindependent.org/billboard"></div><div id="feed_links" class="feed_links"><h3>News Feeds</h3> <a class="rss_feed" href="https://www.newhavenindependent.org/index.php/feeds/rss_2.0/" title="Subscribe to the New Haven Independent RSS Feed">N.H.I. <abbr title="Really Simple Syndication">RSS 2.0 Feed</abbr></a> <a class="rss_feed" href="https://www.newhavenindependent.org/index.php/feeds/atom/" title="Subscribe to the New Haven Independent Atom Feed">N.H.I. Atom Feed</a></div><div id="sponsors" class="sponsors-banners"><h3>Sponsors</h3><div id="nhi_sponsors" class="nhi_sponsors sponsors"> <a id="Sponsor2" href="http://www.cfgnh.org/" target="_blank" title="The Community Foundation for Greater New Haven"></a><div id="seedlings"></div><a id="Sponsor4" href="http://betsygrauerrealty.com/" target="_blank" title="Betsy Grauer Realty"></a><div id="Sponsor5"></div><a id="sponsor_YNHH" href="https://www.ynhh.org" target="_blank" title="Visit Discover YNHH"></a> <a id="sponsor_KF" href="http://knightfoundation.org/" target="_blank" title="Visit Knight Foundation"></a></div><h3 id="h_spd" class="h_spd">N.H.I. Site Design &amp; Development</h3> <a id="dev" class="dev" href="http://smartpilldesign.com/" title="site by Smartpill Design">smartpill design</a></div></aside> </section></div></div><div class="footer row"><footer id="footer" class="footer small-16 medium-16 columns"><div class="row"><div class="footwrap small-16 columns"><p class="f_left copyright">&copy;2005 &ndash; 2018 <a href="http://newhavenindependent.org" title="visit New Haven Independent">New Haven Independent</a></p><p class="f_right spd"> site: <a href="http://smartpilldesign.com/" target="_blank" title="visit smartpilldesign.com">smartpilldesign</a></p></div></div> </footer></div></div></div> <script type="text/javascript" src="/assets/js/min/ojp.entry-plugins-min.js?v=0847060718"></script> <script src="/assets/js/min/plugins-min.js?v=1528424180"></script> <script type="text/javascript" src="/assets/js/min/ojp_entry-min.js?v=1701171511"></script> <script type="text/javascript">(function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();</script>  <script type="text/javascript">_qevents.push( { qacct:"p-a4RoUWp9ToKuU"} );</script> <noscript><div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-a4RoUWp9ToKuU.gif" height="1" width="1" alt="Quantcast"/></div> </noscript></body></html>